why is excel reader removing rows?

I am bringing in an excel file that has multiple unique rows with the same identifier. Identifier in this example is ‘100’

as you can see ‘100’ is listed in first 4 rows:

however, when I bring it into knime with excel reader it only lists 1 row:

How can I stop knime from doing that I need to see all rows of data not just the first row of unique value?

Hi @mb7846,

did you toggle all filter in Excel before you read the file with KNIME?


Hey! No I did not- can you explain?

If you filtered the data in Excel, KNIME reads only the filtered rows from Excel based on my best knowledge.

Ah ok - no I have not filtered any of the rows prior to uploading it to excel reader.

@mb7846, could you upload your file here?

no :frowning: its proprietary - but here is a literal screen shot of the raw data (multiple rows with same initiative number) using 100 as the example:

and here is my workflow snapshot. I am a noob to knime and have a little experience in alteryx. Learning KNIME by Google lol – im guessing my step one is right. step one = pull in my excel file via excel reader:

omgoodness I found it - my settings were wrong. user error! it was reading off of the wrong worksheet!


My idea would be the following:

Uncheck the “Limit data rows scanned” in the Advanced settings.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.