Windows Permission Error Prompt - on Google Sheets Connection

Hi there,

I’ve been running a workflow via a batch file, recently the same workflow has been failing consistently with the following error:
I’ve developed a workflow which pulls data from multiple sheets from Google Sheets, concatenates all workflows and then pushes the concatenated data model to Tableau Server.
I use the following nodes:

  • Google Authentication - configuration set to ‘Credential Location’ - Node, scope Google Sheets Connection (Read) since I want to only pull data
  • Google Sheets Connections - no flow variables
  • Google Sheets Reader - Spreadsheet selected ’ XXXXXXXXX’, Sheet ‘XXXXXXX’. I can see and select the sheets in ‘Open in Browser …’. Memory Policy - cache tables in memory

While I run the workflow using the GUI, the workflow runs and completes successfully. However, when I run the workflow using a batch file - either triggering the batch file using the command-line or using Windows Task Scheduler, the following error is retrieved: setPermissionsTOOwnerOnly
Warning: unable to change permission for owner:

Iv’e exported the preferences file again and replace this file with the previous one in the batch.
Running Windows 10, Mac OSX.

What I’ve done so far to debug the problem:

  • Upgrade to the latest KNIME version. 4.3
  • Run the batch file as Admin.
  • Run KNIME as Admin.
  • Run the batch file both via CMD and via Windows Scheduler.
  • I’ve also changed the default Temp folder of KNIME but that didn’t solve the issue. Permissions on that folder seem to be allow read/write

I’ve looked all over the community forum and searched the web, the suggestions above came from the web and there was also a suggestion the cause it related to Java and the Google API - where individuals solved the issue for their own application not KNIME directly.

None of the above work, I am getting the same error each time.

Has anyone experienced this similar error ?
Does anyone have ideas what else I could try?

@christian.dietz, @Mark_Ortmann, @Kathrin

I customarily do not do this but I’ve hit a wall, did not receive any help from the community and could not find a solution for this for 3-weeks now.

I’ve re-run the workflow now and I noticed that it completes successfully despite the error and/or warning message displayed in the original post.

I hope that you could shed some light on what I am experiencing in any event.

Thanks in advance!