Workflow corrupted?


I have a problem with a workflow which is driving me nuts…
I developed a workflow which is running without problem by itself (I will call it workflow ‘A’). I set up a workflow (workflow ‘B’) which runs this workflow ‘A’ using a 'Call Workflow (Table based) node. This workflow is used to pass input data set to workflow ‘A’ to run it automatically with all input it needs.
At one point, I used workflow ‘A’ by itself with an input file. This file created an issue with knime because now, each time I try to save my workflow I have this wired error message ‘ERROR Call Workflow (Table Based) 0:690 Execute failed: java.nio.file.InvalidPathException: Malformed input or input contains unmappable characters: /site/tl/home/cbaudinaud/work/Knime_data/CL_Generalisation_WK_picklist_CR/Ticket#54101757 \u2014 URGENT Demande de création d’une PickList à partir de BatchID/20190828_Liste_BatchID_CP_DummyBatches_andDupliucates.xlsx’.
I tried to remove this file from my file service, including the whole directory actually but I still get the issue.
My workflow ‘B’ cannot be used anymore - which is very annoying because I use it for automated testing.
Do you have any idea how I can get this fixed?
Thanks in advance for your help,
PS: I’m using Knime 371

For starters I would clean the name from any special charterers. Especially hashtag and the Unicode character and most of all a “/” in the name which is not a folder (or is it). Stick to ASCII characters and underscores.

Then for the call part. I tried to set up an example how to call sub workflows and ‘communicate’ between them.

My impression was that it is best to store and load data instead of transferring it directly.


This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.