Workflow executed successfully but can't see the output


I’m not sure if this is an issue with the settings or if I’m doing something wrong.

When I execute any workflow on the KNIME server, although the workflow is executed successfully, I don’t see the output. For example, the attached workflow connects and extracts some data from the DWH and loads the data into the KNIME Server in the form of a csv file. When I execute the workflow locally, it creates the file on the server. When I execute on the server, I get the message ‘Workflow executed successfully’ but the file is not generated on the server. Same result with other tests I tried.




Hi Kon,

If you want the CSV file to be generated on the KNIME Server whether the workflow is run locally, or on the server you could use a path like: knime://knime-server/path/to/file where the knime-server is the mount-id of the server, and path/to/file is the path to the file in the workflow repository. The easiest way to find that path is to right-click one of the existing CSV files and choose: ‘Copy Location’ > ‘Absolute URL’. That will then negate the need for the Create Temp Dir and Explorer Writer nodes.

You may also want to use the ‘File Download’ node and wrap that into a wrapped metanode. That would allow you to make the file available for download via the WebPortal.



1 Like

Hi Jon,

Many thanks for your help. That worked!