Workflow execution and passing parameters from URL

If I pass in the browser the URL as per below format it works fine:


but if I pass the URL URI encoded as per below, it doesn’t work:


passing the URL as URI for workflow execution and passing the parameters

The problem is that I’m using SAP Analytics Cloud (SAC) to execute the URL and SAC is converting automatically character “:” to “%3A” and then it doesn’t work.

Please help as per URI format should work as well.


1 Like

I agree with @MarcEM , in my opinion, the url encoded should have worked. It should understand that “%3A” represents “:

Hi, yes it worked :slight_smile:

The URL was wrongly code from my side, I added symbol ‘&’ twice in SAP Analytics Cloud, however, the double ‘&’ symbol was populated in the URL just once but URL not working, so it was difficult for me to find the issue…


1 Like

Ahhh, I see @MarcEM . Indeed, that’s hard to see when it only shows 1 & instead of 2 when there are 2.

I’m glad you figured it out then, so there’s no bug per se :slight_smile:

yes, no bug, knime rules :slight_smile: