Workflow freeze & graphics problems with KNIME 3.7

Hi @quaeler,

Thanks a lot for trying to reproduce this. I cleaned a bit my troublesome model removing nodes for confidentiality reason, leaving annotations in order to be able to replicate the bug (I wanted to send it to you today). But after cleaning, I failed to reproduce the bug. Looks like my model needs to have all the nodes it used to have for the bug to show up (!). I’ll try to work on it in the coming days.

The GIF is useful here. When the bug occurs n my side, I simply click in one annotation to edit it. I then change the border color or the font one, clicked back on the border or on the grid itself to get out of the annotation and boom, got a freeze. Also, one thing to note: I have “overlapping” annotations, like the one you have in the GIF, with some of them being sent “at the back”. I honestly do not remember if the freeze happened on back annotations or on all of them. Once I get this replicated on a test model, I’ll send it over to you. Maybe in the meantime, somebody else would come up with the same issue and would attach an example.

Additionally, same as @Joel_P, no workflow node running when freeze occurs.

Hi @JackBibiRoot -

Thanks for the good reply; the OP verified that the fixes currently awaiting merge fixed his freezing on his looping workflow. These fixes contain code that affects the way node rendering is handled in general - so perhaps if your workflow has many nodes and you’re frequently entering and exiting Annotation Edit mode (where the nodes become greyed-ghostly) then this could be the root of your freezing (and the same fix would work for you.)

If you’re feeling adventurous, you could grab the patched workflow editor plugin jar from here:
http://theori.st/take_away/knime/11039/editor.jar (or http://theori.st/take_away/knime/11039/editor.jar.zip if you have supervising software that doesn’t like JAR files to be downloaded).

Then, make sure KNIME is quit; using Explorer, find your knime_3.7.0\plugins\org.knime.workbench.editor_3.7.0.v201811301425 directory. In that directory, rename the existing editor.jar (like editor_jar.bak) so that you still have it around if you want to revert. Then copy the downloaded editor.jar into this directory and run KNIME.

1 Like

Hi !
I’ve installed the new editor.jar but some freezes occurs again. Difficult to find the reproductibles situations : I’ve created a simple workflow (like the gif one) with annotations but no freeze, came back to my workflow and got again some freezes (not at the first annontation editing but after some ones).
For the moment I ran knime with -clean parameter and it seems to be better.

Nop…
So : install new editor.jar, run knime with -clean parameter, open a workflow, edit some annotations (ok) and try to create new one and knime freeze again. It is steel working : the memory of the process changes. I can minimize the windows :

but with trouble. Then I’ve killed the process.
Here is the log between the freeze (8:56) and the restart (9:02) :
2018-12-19 08:29:57,559 : DEBUG : ModalContext : LocalWorkspaceContentProvider : : : Refreshing “/Pol_doc/PolDoc_analyse_donnees”
2018-12-19 08:56:07,452 : DEBUG : main : NodeContainer : : : Setting dirty flag on PolDoc_analyse_donnees 0
2018-12-19 08:56:07,453 : DEBUG : KNIME-Workflow-Notifier : WorkflowEditor : : : Workflow event triggered: WorkflowEvent [type=WORKFLOW_DIRTY;node=0;old=null;new=null;timestamp=19 déc. 2018 08:56:07]
2018-12-19 08:56:30,643 : DEBUG : KNIME-Workflow-Notifier : WorkflowEditor : : : Workflow event triggered: WorkflowEvent [type=ANNOTATION_ADDED;node=null;old=null;new=;timestamp=19 déc. 2018 08:56:30]
2018-12-19 08:56:30,735 : DEBUG : main : WorkflowRootEditPart : : : part: AnnotationEditPart( )
2018-12-19 09:01:13,465 : DEBUG : KNIME-Node-Usage-Writer : NodeTimer$GlobalNodeStats : : : Successfully wrote node usage stats to file: C:\Users\pollet\knime-workspace1.metadata\knime\nodeusage_3.0.json
2018-12-19 09:01:13,728 : DEBUG : KNIME-Node-Usage-Sender : NodeTimer$GlobalNodeStats : : : Successfully sent node usage stats to server
2018-12-19 09:02:14,136 : INFO : main : NodeLogger : : : #########################################################################################
2018-12-19 09:02:14,137 : INFO : main : NodeLogger : : : # #
2018-12-19 09:02:14,137 : INFO : main : NodeLogger : : : # Welcome to KNIME Analytics Platform v3.7.0.v201812041331 (Build December 06, 2018) #
2018-12-19 09:02:14,137 : INFO : main : NodeLogger : : : # Based on Eclipse, http://www.eclipse.org #
2018-12-19 09:02:14,137 : INFO : main : NodeLogger : : : # #
2018-12-19 09:02:14,137 : INFO : main : NodeLogger : : : #########################################################################################
2018-12-19 09:02:14,137 : INFO : main : NodeLogger : : : # #

Hi All

To confirm @quaeler patch resolved my loop related freezing problems - big thanks to Loki!!

I have tried to reproduce the annotation version of the problem but couldn’t make it freeze before or after the patch.

Thanks
John

@Joel_P tant pis - désolé! Hmm… it seems like what you are calling a “freeze” is a different sort of freeze than the OP was experiencing. When you say that it is still working - that you can minimize windows, for example - does this mean that you can interact with other panes in KNIME (for example, you can still scroll through the Node Repository tree?)

If you can still interact with KNIME, could you keep the Console pane open while running and change the logging level to DEBUG (Preferences → KNIME → KNIME GUI, “Console View Log Level”), and then once the problem happens with you, copy and paste out of the console? (You might want to periodically clear the Console before the problem just because there will be a lot of unhelpful verbiage in your copy and paste.)

(I may apologize for my poor english !)
When Knime “freeze” I just can do very little : I can’t use panels, workflow etc. I just can minimize once. And I have to kill the process.
Here is the console log with the freezing. I was on my workflow, creating annotation for testing and try to modify the inside annotation “qffqd” by clicking on top left corner. There is a connector in the same array but I think that was not the case in another problem encountered.
(by the way : what is the meaning of “setting dirty flag on”, the first line after put the consol log level to debug ?)

[Edit] : when I start Kinme again, there is 2 “welcome to Knime…” sheet. And one has this error with this java exception :

(Your English is great.)
Setting ‘the dirty flag’ is internal bookkeeping to say whether or not your workflow needs saving (for example, if you change a node configuration, your workflow is marked as being ‘dirty’ and then when you attempt to quit KNIME or close your workflow, we look to see if the workflow is dirty - and if it is, we ask you if you want to save it first.)

Hmm… so the Console shows nothing useful unfortunately; the 2nd Welcome editor pane problem i have seen before occasionally - but I don’t think it is related to this issue.

If you look inside your KNIME workspace directory (the default is usually in your home directory named ‘workspace’, if you’re not sure where it is,) there is a file named “.log”. If you look at the contents of that file, towards the end after a freeze, do you see any text like stack traces (where a stack trace is like the text you have in your screen capture of a 2nd Welcome page)?

Hi !
Thanks for your following. Indeed there is a lot of stack line in the log. So : open Kinme again with my workflow, create and modify annotation and Knime freezes when I attempts to create an new notation. This occurs at 08:17:07 (line 9357 in the log file). The log continues at 08:20:44 but Knime is steel freezing.log_knime.txt (715.6 KB)

And when I ran Knime again (after killing the process), there are these lines :
!SESSION 2018-12-20 08:30:41.958 -----------------------------------------------
eclipse.buildId=unknown
java.version=1.8.0_152
java.vendor=Oracle Corporation
BootLoader constants: OS=win32, ARCH=x86_64, WS=win32, NL=fr_FR
Command-line arguments: -os win32 -ws win32 -arch x86_64

!ENTRY org.eclipse.ui 2 0 2018-12-20 08:30:44.860
!MESSAGE Warnings while parsing the key bindings from the ‘org.eclipse.ui.commands’ and ‘org.eclipse.ui.bindings’ extension point
!SUBENTRY 1 org.eclipse.ui 2 0 2018-12-20 08:30:44.860
!MESSAGE Cannot bind to an undefined command: plug-in=‘org.knime.workbench.editor’, id=‘knime.commands.editor.gridSettings’

[edit] : same problem with an another workflow (the first one being closed). When Knime is freezing, the log is appended each time I tried to do something. There’is :
!MESSAGE Unhandled event loop exception
!STACK 0
org.eclipse.swt.SWTError: No more handles

or

!MESSAGE Unhandled event loop exception
!STACK 0
org.eclipse.swt.SWTError: No more handles

or

!MESSAGE An exception occurred while notifying part listeners
!STACK 0
java.lang.NullPointerException
at org.eclipse.ui.internal.WorkbenchPage.updateActivePartSources(WorkbenchPage.java:336)
at org.eclipse.ui.internal.WorkbenchPage.updateActivations(WorkbenchPage.java:300)
at org.eclipse.ui.internal.WorkbenchPage.access$18(WorkbenchPage.java:293)

and the last one (before I killed the process) :

!ENTRY org.eclipse.ui 4 4 2018-12-20 08:46:15.626
!MESSAGE The final top level window org.eclipse.e4.ui.model.application.ui.basic.impl.TrimmedWindowImpl@fe87ddd (elementId: IDEWindow, tags: [topLevel], contributorURI: platform:/plugin/org.eclipse.ui.workbench) (widget: null, renderer: null, toBeRendered: true, onTop: false, visible: true, containerData: null, accessibilityPhrase: null) (label: null, iconURI: null, tooltip: null, context: null, variables: , x: 13, y: 45, width: 1792, height: 1014) was just removed
!STACK 0
java.lang.Exception
at org.eclipse.ui.internal.Workbench.lambda$12(Workbench.java:1969)
at org.eclipse.e4.ui.services.internal.events.UIEventHandler$1.run(UIEventHandler.java:40)

This is helpful - thank you.

Could you give me a screen shot of the entire KNIME window as you would normally have it configured when you’re running into this issue? (Blurring out in Photoshop or similar whatever you might consider to be confidential information.)

Also, could you give me a rough idea of the number of nodes and annotations in your workflow?

Also, also, just to be sure - this log file was produced by KNIME running with the patched jar copied into your workflow editor plugin, or not?

Hi quaeler,
There is about an hundred node I think and 13 annotations on the workflow considered (and about 75 nodes and 10 annotations on the other one). Kinme is running with the patched editor.jar as you’ve pointed to us.
Note : I will be in holidays for a couple of weeks and perhaps will have difficulties to connect on internet.

Thank you for the screen shot and further information; i have a new editor.jar for you to test which should address your problem - though if you’re already on vacation, we might have a dot-dot release with the fix in it by the time you return.
(bonnes vacances!)

Hi @Joel_P, @MH, @yannick_carbonneaux and others who have had issues with KNIME 3.7.0 freezing on Windows when working with annotations and loops; the nightly builds starting in the early part of January should have the fix merged in for the annotations related problem, and the nightly builds, as of this writing, already have the fix for loop related problem.

Alternatively, you can grab the patched workflow editor plugin jar, which addresses both issues, from here:
http://theori.st/take_away/knime/11151/editor.jar (or http://theori.st/take_away/knime/11151/editor.jar.zip if you have supervising software that doesn’t like JAR files to be downloaded).

Then, make sure KNIME is quit; using Explorer, find your knime_3.7.0\plugins\org.knime.workbench.editor_3.7.0.v201811301425 directory. In that directory, rename the existing editor.jar (like editor_jar.bak) so that you still have it around if you want to revert. Then copy the downloaded editor.jar into this directory and run KNIME.

Please report back whether you still experience freezes if you use the patch jar. Thanks.

4 Likes

Hi, works perfectly now! No crash since one hour

Thanks!
Yannick

3 Likes

All changes should also be in the nightly build tomorrow.

2 Likes

Hi !
It’s seemed to work with the patch workflow editor plugin jar.
Thanks a lot and happy new year !!

3 Likes

Wonderful. It works like a charm with the new.jar. Thanks a lot for your help with this.

3 Likes

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.

Just for the records: Fix is part of KNIME Analytics Platform 3.7.2.

2 Likes