Workflow freeze with Knime 3.7.1

Hi,

We have been following the workflow freeze topic previously posted and now closed as we encountered the same issue in January after updating from 3.6. We have large workflows with many loops, metanodes and wrapped metanodes.
We continue (multiple desktops) experiencing the same freeze issues previously noted with 3.7.0. We had never had issues like that with any versions before 3.7 but now it seems to keep occurring randomly a few times a day. Does anybody else still have these problems?

Thanks, Greg

2 Likes

There is ongoing discussion here Workflow Freeze - if you have a workflow that you can provide which is presenting a freeze regularly, that would be great, though i infer from “randomly” that it’s not strictly reproducible.

Can you characterize a common theme across the workflows that are being used on these installs? (loops, metanodes, specific third party nodes, specific core nodes, … )

Sorry, missed that other discussion track. I cannot share the workflow unfortunately. But we are using a lot of loops, and metanodes that may have been contributing this problem in 3.7.0. We also have external tool nodes and 3rd party nodes from ChemAxon. Any logs or other sources of information that can be helpful for you?
This is really becoming a severe problem for us.

You could install Sleak with the instructions cited here: Workflow Freeze (and further clarifications in the thread item linked to in the above reply.)

Thanks. Will try and see if something emerges.
The only clue I have is that similar workflows did never before cause any issues so it must be something that was modified from 3.6 to 3.7. When we tried to go back to 3.6 we noticed that workflows saved in 3.7 did not work in 3.6 (as expected) and the major error messages had to do with strings.

No, something definitely broke in 3.7.0, which i thought we had completely addressed in 3.7.1 but apparently have not completely addressed.

If you moved from 3.7.0 to 3.7.1 by doing an in-app-software-update, could you also try picking one or two of the freezing-installs and deploying 3.7.1 as an entire downloaded app? (I know that’s a pain in the ass as you’ll need to install additional plugins freshly - but it will at least rule out something having gone awry in the update process.)

My current install was done fresh. After the frustrations I completely uninstaílled 3.6 using the windows uninstall and freshly installed 3.7.1 using the installer version then reinstalled all the extra extensions. Do you mean the zipped 3.7.1 download version might be better?

No - that should do it. I meant Help → Install New Software… versus downloading the entire Analytics Platform (as ZIP, or installer, …) from the KNIME website.

In case you didn’t get a notification from the forum - please see here: Workflow Freeze

1 Like

I did get it, thank you so much. I just downloaded the jar and will start using it. I will report back here once it is clear if this solves our issues. Thanks again!

Things have become much better, but today I got another freeze. The log shows the below message:

2019-02-17 20:54:24,587 : ERROR : main : NodeContainerEditPart : : : The dialog pane for node ‘Standardizer 0:9079:9168:8934’ has thrown a ‘SWTError’. That is most likely an implementation error.
2019-02-17 20:54:24,587 : DEBUG : main : NodeContainerEditPart : : : The dialog pane for node ‘Standardizer 0:9079:9168:8934’ has thrown a ‘SWTError’. That is most likely an implementation error.
org.eclipse.swt.SWTError: No more handles
at org.eclipse.swt.SWT.error(SWT.java:4559)
at org.eclipse.swt.SWT.error(SWT.java:4448)
at org.eclipse.swt.SWT.error(SWT.java:4419)
at org.eclipse.swt.widgets.Display.create32bitDIB(Display.java:1018)
at org.eclipse.swt.widgets.Display.createIcon(Display.java:1101)
at org.eclipse.swt.widgets.Decorations.setImages(Decorations.java:1028)
at org.eclipse.swt.widgets.Decorations.setImages(Decorations.java:1096)
at org.eclipse.jface.window.Window.configureShell(Window.java:368)
at org.knime.workbench.ui.wrapper.AbstractWrappedDialog.configureShell(AbstractWrappedDialog.java:104)
at org.knime.workbench.ui.wrapper.WrappedNodeDialog.configureShell(WrappedNodeDialog.java:214)
at org.eclipse.jface.window.Window.createShell(Window.java:493)
at org.eclipse.jface.window.Window.create(Window.java:425)
at org.eclipse.jface.dialogs.Dialog.create(Dialog.java:1096)
at org.knime.workbench.ui.wrapper.WrappedNodeDialog.create(WrappedNodeDialog.java:312)
at org.eclipse.jface.window.Window.open(Window.java:783)
at org.knime.workbench.ui.wrapper.WrappedNodeDialog.open(WrappedNodeDialog.java:182)
at org.knime.workbench.editor2.editparts.NodeContainerEditPart.openNodeDialog(NodeContainerEditPart.java:865)
at org.knime.workbench.editor2.editparts.NodeContainerEditPart.openDialog(NodeContainerEditPart.java:773)
at org.knime.workbench.editor2.editparts.NodeContainerEditPart.performRequest(NodeContainerEditPart.java:344)
at org.eclipse.gef.tools.SelectEditPartTracker.performOpen(SelectEditPartTracker.java:194)
at org.eclipse.gef.tools.SelectEditPartTracker.handleDoubleClick(SelectEditPartTracker.java:137)
at org.knime.workbench.editor2.WorkflowSelectionDragEditPartsTracker.handleDoubleClick(WorkflowSelectionDragEditPartsTracker.java:126)
at org.eclipse.gef.tools.AbstractTool.mouseDoubleClick(AbstractTool.java:1069)
at org.eclipse.gef.tools.SelectionTool.mouseDoubleClick(SelectionTool.java:527)
at org.eclipse.gef.EditDomain.mouseDoubleClick(EditDomain.java:231)
at org.eclipse.gef.ui.parts.DomainEventDispatcher.dispatchMouseDoubleClicked(DomainEventDispatcher.java:291)
at org.eclipse.draw2d.LightweightSystem$EventHandler.mouseDoubleClick(LightweightSystem.java:518)
at org.eclipse.swt.widgets.TypedListener.handleEvent(TypedListener.java:197)
at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:86)
at org.eclipse.swt.widgets.Display.sendEvent(Display.java:4428)
at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1079)
at org.eclipse.swt.widgets.Display.runDeferredEvents(Display.java:4238)
at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3817)
at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine$5.run(PartRenderingEngine.java:1150)
at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:336)
at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine.run(PartRenderingEngine.java:1039)
at org.eclipse.e4.ui.internal.workbench.E4Workbench.createAndRunUI(E4Workbench.java:153)
at org.eclipse.ui.internal.Workbench.lambda$3(Workbench.java:680)
at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:336)
at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:594)
at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:148)
at org.knime.product.rcp.KNIMEApplication.start(KNIMEApplication.java:144)
at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:134)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:104)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:388)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:243)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
at java.lang.reflect.Method.invoke(Method.java:498)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:653)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:590)
at org.eclipse.equinox.launcher.Main.run(Main.java:1499)

Ok - thanks for the update. I’m at a loss presently, but will keep looking.

Hi @gmakara -

I’ve found an image leak when closing the editor panes of the metanode family, and have made another patch editor.jar (this version contains the fix that was in the original version you downloaded, as well.)

Please download it from the same location ( http://theori.st/take_away/knime/11342/editor.jar / http://theori.st/take_away/knime/11342/editor.jar.zip ) and see whether is appears to solve your issue.

Thanks for your assistance.

1 Like

Thank you! I have installed the new jar, will report back on further issues in case we run into any.

First of all - thanks very much to both of you for so tenaciously pursuing this problem! I am suffering from the same issue and have a critical deadline coming up, but unlike @gmakara I don’t have the luxury of reverting back to KNIME 3.6.

I’ve got a huge workflow originally from KNIME 2.12 that I am now migrating up from KNIME 3.5.2 to KNIME 3.7.1. It contains 7 large MetaNodes with the last containing about 500 individual nodes. Yesterday I couldn’t even open that last MetaNode without my workflow freezing. But after applying your latest patch things are working much better!

Not being able to open the MetaNode has put me on a path of moving all of those nodes out into a separate workflow. I’ve seen discussions on calling one workflow from another, so I’ll look into doing that for these nodes.

But right now I can report that, with the patch, I can:

  1. open the MetaNode
  2. select and copy all 500 individual nodes
  3. paste all 500 into a new workflow

The whole process took almost 30 minutes of waiting but it worked!

1 Like

Could you let us know, if possible, how that paste performance compares to doing it in 3.5.2 (if you’re able to without much difficulty?) ((after your critical deadline has come to pass, of course.))

The same copy-paste in KNIME 3.5.2 took 5 minutes flat!

I happened to have the old workflow up to help me with the porting so it was easy to do.

That’s a surprising performance degradation :- (

Thanks for the report - we’ll look into it.

If you have time after your deadline, and if you feel comfortable doing it, I would like you to get a snapshot dump of the running state of your KNIME (using a program called jstack ( https://docs.oracle.com/javase/8/docs/technotes/guides/troubleshoot/tooldescr016.html .))

Let me know if you have the time after your deadline passes.

I just opened a new topic that is possibly related to this topic. See: KNIME 3.7.1 Configuration Dialog Displaying Wrong Settings

@quaeler You can have my whole workflow if you want it. It’s confidential so I can’t post it online, but I already have an NDA with KNIME so I can send it directly to you (I’m assuming you are a KNIME employee?). You’ll have to install two plugin collections of nodes to get it to work (a public plugin and a private plugin) but I’m happy to get this to you if you think it will help.