workflow import problem, missing nodes 2.5.4 to 2.6

Hi,

I have built a knime workflow using knime 2.5.4 on 64-bit windows. However now, when I try to open it with knime 2.6 on a Mac, I do not get the entire workflow. Many nodes dissappear and I have to again look for them and re-put the into the workflow. I realized that this is caused in part by some differences in the names of nodes, but in many cases the node has the same name and still it disappears from the workflow imported. I wonder if there is a way to solve that.

Thank you.

Best, 
Mohamed

Hi Mohamed,

I have the same problem if I get a workflow from somebody who has extensions installed that are missing on my machine. Sometimes nodes are deprecated and missing in newer versions of the extension or even worse a developer decided to rename the node classes.

It would be nice if the KNIME team could implement something like ghost nodes and ghost connections that are inserted in workflows when nodes are not found in the current repository.

Can you check on your MAC if all required extensions are installed? The error messages in the KNIME console should help you finding out which nodes are missing.

Best regards

Guido

I have never seen this on 32bit windows. You may find you are missing some knime extensions or community contributions.

try going to the menu and checking install extensions to see if anything is missing from your install. For community, see the instructions, on installing these in the menu of this forum.

as far as I have seen, knime do keep ghost nodes present with the word depreciated in the node title in the workflow.

 

Simon

Hi Mohamed, 

unfortunately there have been several changes in the nodes with the release of KNIME Image Processing 1.0, and therefor some nodes may be missing after importing a workflow. With the release of 1.0 we will avoid this in the future and just mark "old" nodes as desprecated. 

 

For now we can help you whenever possible to get your workflows run with KNIME Image Processing 1.0. If you like you could send me your current workflow and I could have a look what to change? 

Sorry for the circumstances,

Christian

Hi Guido & Simon,
I am so sorry for the late reply...I did check that I have all the knime extensions and community contributions up to date and still the problem persists. I think th reasons are mentioned in Christian's message above.
 

Hi Mohamed,

OK the problems are the following:

The workflow was created using the beta build of KNIME Image Processing (0.8.0).
With KNIME Image Processing 1.0.0 we made a lot of changes to somehow try to be backwards compatible in the future, this means e.g. that a workflow created with 1.0.0 will still run on 1.1.0.

So there have been a lot of renamings, changings etc, and your current workflow can't handle this.

Well, I started to rebuild your workflow with KNIME Image Processing 1.0.1. If you could provide me some example images, I can test it and configure it the way it was configured before (just send them to christian.dietz@uni-konstanz.de if you like) with using the new nodes. (see list of changes below).

Sorry again for the circumstances, we try hard that this isn't necassary anymore in the future ;)

Have a nice weekend,

Christian

-------------------------
Some changes:

  • Table To Labeling is now integrated in Image Group By (Group by labeling, choose BitMasks to aggregate (Labeling Composition) and configure the Labeling Composition tab.
  • Internal renaming of Connected Component Analysis, that's why it got lost.
  • Binary Operations are now called Morphological Binary Operations (it's much more powerful now).
  • IJ Snippet is now called ImageJ Macro
  • New Segment Features break old SegmentFeature configuration

 

 

Hi Christian,

Please check your e-mail for the example images. Thank you for your great help.

Best Regards,
Mohamed

Hi Mohamed,

I hopefully got it all right now, i just sent you and e-mail with a new version of the workflow. maybe you could go through it and check if everything is done right?

I didn't configure the segmentoverlay views, because you know best what you want to have a look at. Anyway:

  • Amazing workflow :)
  • While I was reconfiguring your workflow I figured out, that it's really somehow not user friendly if the row-id changes after the ImageGroupBy. I will discuss that with Martin and we will come up with a (hopefully) better solution with the next release. Btw. this explains the "new" rowId nodes which are plugged in before some joiners
  • Just a hint: you can now use on many nodes: Right-Click -> TableCellViewer directly. Makes a lot of things easier (inspecing images etc).

If you have any questions/suggestions/feature requests feel free to contact us, we are really happy for feedback!!

Have fun with your workflow!

Christian

Hi Christian,
I am incredibly sorry for the late reply. Please find attched my workflow, screen shot of the error log, and the same error log as a txt file. I would be grateful if you can have a look at it and help me with the issue of the missing nodes. I updated to 2.6.1 today before I opened the workflow. Thank you.


Best,
Mohamed

Hi Christian,


I tried the workflow you sent me. I no longer get any error messages when I open it :)
Thank you very much for your kind help :) 
I also want to point out that I actually did not build up this entire workflow from the scratch, but I got a sort of 'back bone' workflow from the RNAi screening facility at the BioQuant Heidelberg which I started with and modified largely to serve my puspose. 

Thank you again :)

Best,
Mohamed