Wrapped Matanotes and Quickform nodes - reselection after pressing 'back' on Webportal doesn't work


#1

Hi,
Sorry in advance that I have another question! I’m trying to update many models to go on the new Server…

I have a workflow to run on the Webportal. I’ve created a new Column Selection quickform node which is wrapped in a wrapped metanode.

When running the workflow on the WebPortal, the first execution works fine, user can select the required column and run the rest of the workflow and gets a report. However, if the user then selects ‘Back’ and changes her column selection, the workflow executes again but still using the OLD column that was selected originally…

Have I missed something in the Wrapped Matanode setup or has someone else come across this and found a solution?

Thanks in advance,

Mike


#2

Hi michazeidan,

I’ve prepared a workflow for you to test, could you please try it on your server? It works as expected for me:
ColumnSelectionWebPortal_2.knar.knwf (12.7 KB)

I can suggest that the problem is somewhere else, probably in the way you’re using the selected column afterwards. If you could provide a sample workflow it would be more clear.

Best,
Anna


#3

Hi Anna,
Many thanks for looking into this. I’ve installed your workflow and it works fine on the Webportal. No issues with the ‘Back’ button. comparing the workflows it looks like a key difference is that yours ends with a wrapped metanode containing the text output view, whrereas mine ends with a BIRT report. So I think the issue might be going back from a BIRT report view. In the workflow I’ve not wrapped my ‘data to report’ nodes into a wrapped metanode. Should I do?
Thanks,
Mike


#4

ColumnSelectionWebPortal_3.knwf (21.3 KB)

Hi Anna,
Please see attached your original workflow but modified to now write to a BIRT report. Works fine first time, but notice that when you press the ‘Back’ button and change the setting, this setting isn’t changed in the report - the report just showed the first output again…
So I definitely think that the issue has something to do with BIRT-KNIME interaction. Any advice on how to fix this…?
Thanks again!
Mike


#5

Hi Mike, Can you confirm the KNIME Server version that you’re using? (e.g. 4.x.y)

Thanks,

Jon


#6

Hi Jon,

Version 4.6.1,

Thanks,

Mike


#7

Hi Mike,

Sorry for the late response. You’re correct, looks like a bug in the KNIME-BIRT communication when the workflow is executed on the WebPortal. I’ll create a bug ticket.

Best,
Anna


#8

Hi Anna,

Thanks for letting me know. I look forward to this bug being fixed (I guess this will be in the next version of the KNIME server?). Until then, I found out that if we use the old deprecated ‘subnode’ instead of a ‘wrapped metanode’ the workflow on the webportal returns an error on pressing the ‘back’ button after the first execution, BUT if you press the ‘back’ button twice… it allows you to make a new column selection, run the workflow and it applies the changed settings correctly in the final report.
As this is the ‘lesser of two evils’ I’ll use the subnode option until the bugfix is in place.
Thanks again for your help,
Cheers,
Mike