Write to Excel Template Variable Issue


I am trying to use the write to excel template to update a specific worksheet in the excel workbook. The issue that I am having is that I cannot get any variables to show up in the extension when I try to use them.

As an example, I have a workflow set up that will go into a folder and find the latest file in that folder. It will then rename that file with today’s date, and I want the extension to use the output of that as a variable into the output of the write to excel template. But it does not show up in the drop down of the extension.

1 Like

Hi @languy22,

could you provide a small example workflow to show the issue?
Will try to give you a solution :slight_smile:

I work with some sensitive data; how can I include that to protect the data? I can include a picture of the workflow and explain what it does? Would they work?

Hi @languy22,

dummy data which shows your problem would be enough.
If that is not possible a screenshot would work as well :slight_smile:

I have attached a picture. Basically, the first line goes onto a network drive to a specific folder. If sorts and finds the latest file in the folder, changes the name to reflect today’s date.

The second line goes to an oracle database grabs the data joins it, filters and sorts it.

Finally, the write to excel template opens the file overwrites a specific worksheet should save it with the new name from the string above.

1 Like

Thanks, will try to look into more detail tomorrow :+1:

I have taken a few more screen shots to see if it helps you diagnose it more. Thanks in advance.

1 Like

Hard to tell from the screenshot, but it seems to me at first glance that you might want to try using a Table Row to Variable node since it looks like you are trying to pass a single value instead of using a Table Column to Variable node.

1 Like

Thanks for the hint. I have made some progress. It seems that the variables show up now but none of the “path” ones show up in the picker drop down. Not sure why. See below pictures. I did notice I have to add a database connector to String to Path to show up correctly.

There is also a “String to Path Variable” node that you could after turning a string into a variable as another approach. I still don’t see anything else in the screenshots to go by…

I would switch the node monitor over to Variables using the 3 dots and see if the path variable is present where you are creating it.

1 Like

The main issue I have is that if I use the built in Excel Writer node all of the paths show up normally, but they don’t in the Write to Excel Template node. I believe there is an issue in the excel write to template node. See below picture to show how it looks in the Excel Writer node.

this is what I get when I run the Table Row to Variable on the Variables output.

I just tested it on my end. It needs to be sent a string variable. If you go to the flow variables tab, then you can see that “path_or_url” is a String variable.

Working on my end with a path sent as a string variable though.

1 Like


We found that out also, but the problem is doing a string doesn’t pull in the SMB information into the node and it then doesn’t know where to go. You see how the new column has “connected, smb://…” that is needed for when I run it on the knime server.

1 Like

Did you try converting your final path to string after you include the SMB info? Can’t troubleshoot that one for you since I am not using server yet.

1 Like

Yeah, we did but you lose the SMB information, so it dies.

:thinking: Have you tried Path to URL, Then URL to String? After that I am out of ideas…

1 Like

Hi @iCFO ,

Thanks anyways that at least narrowed down the problem. :partying_face:
In the worst case I will just have to add path support to the node :slight_smile:


Great node by the way! @AnotherFraudUser

This was my first time using it, but it is a nice clean solution to incorporating data into a working / formatted excel doc.

1 Like

@iCFO thanks - glad to hear :slight_smile: