XLS Cell Formatter doesn't work in Sharepoint (word wrap)

Hi, I’ve been testing Excel formatting but I’ve found that when I try to read & write the file from Sharepoint some formatting doesn’t work correctly (but it does with local files).

This cell here is meant to have word wrap. The option is selected above when I open the formatted file but it’s not actually wrapped.

This is what it should look like.

All other formatting options seem to work correctly except word wrap in Sharepoint.

Hello @plattrk ,

for the better understanding could you please tell us which KNIME version and which specific node do you use? It would be more useful if you could share at least a screenshot of the workflow or the workflow itself what you use.

Many thanks,

Hi Dora,

I’m using KNIME 4.4.4. Here is a screenshot of how my workflow looks:

The relevant nodes are:
Microsoft Authentication
Sharepoint Online Connector
XLS Control Table Generator
XLS Row & Column Sizer
XLS Cell Formatter
XLS Formatter (apply)

The file is correctly created in Sharepoint. The column size is set correctly (20 point) but the word wrap does not appear on the online file.

This works correctly with local files but I found that it stops working once I apply it to an excel file in Sharepoint.

Thank you @plattrk !

If I am right you tried it now for the first time, so it is not an issue that it worked in the past but now somehow it stopped working well?


Yes, this is the first time I’ve tried using it on Sharepoint.

Hello @plattrk ,

thank you for the info.
Is the same happening if you select the “auto-size” function instead of setting the column size to 20 points? (In the “XLS Row & Column Sizer” node.)


Yes, I’ve tried it now with autosize (before and after the cell wrap node) and it has the same result where the word wrap doesn’t work.

Hi @plattrk ,

I managed to reproduce this error. I opened a Jira ticket for this bug (number AP-19273) which will be fixed in the upcoming version(s) of AP.
You can find ticket numbers in the changelogs document (Changelogs | KNIME) to follow up whether this issue is fixed or not. Thank you for your contribution!

Kind regards,

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.