xmx batch mode


There is a way to set the xmx parameter inside a batch execution?


unless you can provide -Xmx2g (for example) as a param when you call KNIME I suspect you would need to edit the .ini file. 

I tried knime.exe -Xmx2g -consolelog and it still used the -Xmx8g from my config file. 

Have you tried with -vmargs before that?

It works with: -vmargs -Xmx8192m -Xms2048m

Only one question, if i remove the xms i have "Error occurred during initialization of VM Too small initial heap"

Why? i can't see the xms parameter inside knime.ini


I'm trying to use the vmargs inside a batch execution

D:\"Program Files"\knime_2.9.1\knime.exe  -nosplash  -reset



-application org.knime.product.KNIME_BATCH_APPLICATION

-workflowFile="X :\MKSAS\SW\P\KNIME_WKF\WKF\00_TEST.zip"


-workflow.variable=WorkDir,"\"X:/\MKSAS"",String -workflow.variable=KNIME_VERS,9,String   -vmargs -Xmx1024m -Xms512m
The job ends correctly but take too much time and arise a warning:

[GenericPropertiesCreator] classloader in use is not the system classloader: using static entries in weka/gui/GenericObjectEditor.pr ops rather than dynamic class discovery.

The change of the values of xmx and xms don't resolve the problem

If you pass -vmargs as a command line argument it will override all vm arguments from the ini file. I.e. arguments not specified on the command line will not be used. One critical parameter, especially if you are using many extensions, is the MaxPermSize. Therefore I suggest you change the parameter in the ini file. Or copy the ini file and point the batch executor to it with "--launcher.ini" (see also http://help.eclipse.org/indigo/index.jsp?topic=%2Forg.eclipse.platform.doc.isv%2Freference%2Fmisc%2Fruntime-options.html).

The warning from the GenericPropertiesCreator can be safely ignored, this comes from Weka and also occurs in GUI mode (but you don't see it because usually there is no console).

Thanks, i'm satisfied

With --launcher.ini="%path%" raise an error of Unknown parameter. If i remove the "=" it works.