Analytics Platfrom 3.6.0 Loads Extremely Slowly

v. 3.6.0 takes forever to load. If there’s a fix, could someone post it with clear steps?

Hello @rfeigel -

Have you tried running KNIME with the -clean option in your knime.ini file? I was having the same problem, and this improved load time for me.



Thanks for the reply, but it didn’t seem to help much. Is the ini file sensitive to where I put the -clean command?

It shouldn’t matter where in the ini file you put the -clean command.

Sorry that it didn’t seem to have an effect. Let me check internally and see if I find something else that will help. I’ll get back to you.

That’s right. I noticed the longer loading time too.
I hope it would be fixed in future updates.:pray:

I have the same issue. very slow to start, sometimes fails completely and have to kill knime.exe in task manager and retry.

The slow part happens BEFORE any add-ons start loading!

Do you use any antivirus? (It might worth adding an exception after an initial check for viruses as it can slow down the start.)

Yes, it’s a company provided machine. But the loading wan’t this slow before 3.6 and never failed. So something must have changed.

I’ve been doing some additional testing on this. One thing I’ve noticed is that KNIME startup time can be quite long after initial system boot, but subsequent startups take about half the time. @beginner and @rfeigel, are you seeing similar behavior?

It’s slower in general but when it was extremely slow or crashed was after installing updates.

With machine running and having just closed knime (eg memory should be hot):

  • KNIME 3.2.1 loads in 25 seconds
  • KNIME 3.6.0 loads in 50 seconds

So pretty much double the time. Both have pretty much same extensions installed. The slow part is actually after selecting workspace and before extensions are getting loaded.

1 Like

Dear @ScottF,


I agree with this:

And this problem has appeared since recent update (3.6.0).

Can someone confirm that’s not the Anti Virus problem that @aborg was pointing at?

We are aware that the (initial) bootstrapping after applying updates requires extra time. This bundle resolution should be cached so any subsequent start-up should be considerably faster. My installation, which contains all possible extensions available through KNIME or the public community repository, takes ~20s to start. (Standard laptop running Linux.)

I surprising have an option to disable anit-virus, at least that what the anti-virus software says but no idea if it actually is completely turned-off. It does not speed up performance.

But another important aspect in my case is that this is running in a virtual machine. Maybe that has an impact albeit it was no issue in previous versions.


I just switched to 3.6.1 and loading the workspace takes extremely long. I’m talking minutes and minutes here. Subsequent loading of the application takes forever too.

Is there a solution to this? I just changed the -Xmx setting in knime.ini to make sure memory wasn’t a problem, but it didn’t help.

Loading a very simple workflow also takes forever.

Any other solutions to help speed up starting the application and opening workflows?


how to enable the clean command in knime.ini?

Just put the text -clean on its own line in the knime.ini file, and start KNIME. (You’ll want to remove the -clean option later, since having it run every time KNIME starts will increase startup time)

As an aside, if you are experiencing slow startup on a Windows machine, you can try adding exceptions to your Windows Defender configuration, as described here:

1 Like

Thank you @ScottF! @Safak 's solution really helped.