Appending a string

Hello,

I need to append a string based on a rule. I want all of my strings to be 5 characters.

Input:

string number
aaa 3
hhh 3
abhag 5
aq 2
p 1

Output:
string
00aaa
00hhh
abhag
000aq
0000p

Is this possible?

Thanks in advance :slight_smile:

@zielinska_km the function should be padLeft in the Column Expressions – KNIME Hub

padLeft(column("column1"),5 ,"0" )

4 Likes

I get error message: Compilation of script failed: Cannot invoke “javax.script.ScriptEngine.eval(String)” because “engine” is null
What should I do?

@zielinska_km check if you have installed the extension and maybe provide a sampel workflow that shows what you are doing. Also make sure you have the latest KNIME version.

Hi @zielinska_km

You can use the String Manipulation node.
image
gr. Hans

4 Likes

I have installed the extension, but I still get the same warning.

Hello together

I have the same error. @zielinska_km were you able to solve the problem in the meantime?

Or does anyone else have any ideas?

Thanks for the help.

Hello @rittiner,

and welcome to KNIME Community!

We can only guess. If you share workflow example I’m sure someone will take a look at it and help you. Simply put some data into Table Creator node and follow it with node that gives you above mentioned error. This topic might help you:

Br,
Ivan

It does not matter what function I use in the expression editor.

I saw this passing by recently (which resolves around the same error)

If the steps mentioned in that topic do not resolve the issue, I would say @ScottF or another teammember has to jump in again.

And they will be asking for log files :wink:

1 Like

@rittiner and @zielinska_km -

Sorry for the trouble here, I will file a ticket (EDIT: filed, AP-19544) and ask our developers to look into this strange behavior with the Expressions nodes. In the meantime, is it possible that a fresh installation of KNIME AP will resolve the issue? I have a suspicion that this maybe due to a corrupted update from a previous version of KNIME - but this is only a suspicion and I may be wrong.

Can I also ask each of you to confirm which version of KNIME AP and operating system you are using?

@ScottF thank you for the quick reply. In my case, the fresh installation of the new version did solve the problem. Thank you for your help.

2 Likes