Can not open Knime workflows nor create new workflows after migration to a new Drive

Basically the title.
Additionally I get this error:

java.lang.IllegalAccessError: tried to access method org.knime.core.node.workflow.WorkflowContext$Factory.(Lorg/knime/core/node/workflow/WorkflowContext;)V from class org.knime.core.node.workflow.WorkflowManager
Here is the log:

knime.log (3.0 MB)

Could you give us a little more context (system, what new drive) and maybe you delete the log and try to start KNIME again so we might have a look at the core information.

Then you might try a -clean restart once, and make sure no additional instances of KNIME are run and you have access to your knime-workspace.

KNIME start with -clean option in knime.ini

Hi @mlauber71,

I am using Windows and exchanged my HDD with a SSD.

EDIT: I tried it with the clean option and it still shows the same error.

Do you use Dropbox or Microsoft OneDrive for your knime-workflow.

You should make sure all three of your meta folders are accessible

  • the folder where the KNIME program is (you can just create a new one with a fresh version)
  • The knime-worspace folder where all your workflows are which is the most important one and should not be corrupted
  • The folder where KNIME stores the temporary files

All three must be accessible there must be enough space and they must accept complex folder names with special characters.

A clean restart or new installation might be an idea along with making sure your SSD is structurally ok.

Hi @mlauber71,

I will look into it.

The plug-in which seems to produce the errors is the eclipse plug in.

Does this piece of information help you?

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.