Unable to save workflow.

Hi all,

I’ve created a workflow on Knime but I am unable to save it. When i try to export it, the file size is extremely large but I am then unable to import it back in (i always get an error). The “Save As” function doesnt work either as I cant select the LOCAL workspace so I’m really scratching my head here.

Please help.

Hello @daryl,

welcome to KNIME Community!

You can’t save workflow so you export it? You can do that but then you don’t have any changes in imported workflow so seems to me this doesn’t make sense.

What is the name of the workflow you are trying to save? What KNIME version and OS are you running?


1 Like

Is it possible that your knime-workspace is in a Microsoft OneDrive folder?

Could you provide us with more details about your operating system and setup in general.

1 Like

Hey all, thanks for the reply! Im currently running 4.1.4 on windows 10 64bit. My workspace is set as my local drive within documents. I believe it is in the default folder Knime_Project that was created. I was afraid the workflow would be lost if my computer crashes, hence why I attempted to export the project in the mean time.

Unfortunately I’m quite new to the program so I’m not sure of how to troubleshoot the issue. Do let me know if you need me to provide any more info!

You might want to read these entries to learn about your 3 locations of KNIME data.

You could (and maybe should) im- and export your workflows or group of workflows to save or share your work. If you want you could also include full data and the latest status but that would cost disk space:


I’ve tried to run the steps for importing workflows but I’m getting and error when importing which suggests that isnt working for me. Not only that, the export seems to archive the entire folder and its getting exponentially larger each time I do it.

I decided to use someone else’s workflow and replace it with the nodes I’ve created, but when I go to save as it still produces this error message:

In your dialogue you have a “/” at the start. You should try deleting that and just use the browse function.


I’d also suggest you try to browse to your desired location, and not give any path there. Try to save it first to the workspace, and then to export.



Hey Both,

Unfortunately deleting the “/” doesnt do anything and I’m unable to select any available drives as it’s greyed out as an option. It does seem to be saved in a folder within the workspace but i realised when exporting, I can’t export only that file - it always ends up exporting the whole workspace. I’ll work on reinstalling knime and hopefully that does something!

Hello @daryl,

have you had any success with reinstalling KNIME?


Hi Ivan,

Yes actually reinstalling the software and allowing it to reset a default workspace solved the issue fortunately.


Hello @daryl

Great! Sometimes that’s a way to go :wink:


This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.