Can not solve the following error in Python script from LabsExecute failed: Last batch index is 26040, but maximum batch index is 2277.

Dear fellow KNIME user,

I face a similar issue as discussed here. I am using KNIME 4.6.3 and KNIME Python Integration (Labs) 4.6.5. When I run a nested loop in ‘Python Script (Labs)’ using my dataset, I get the following error:

“Execute failed: Last batch index is 7314, but maximum batch index is 786.”

I tried reproducing the error using artificial data (see attached flow), however, then it works fine… I can not share the actual data unfortunately.
Also I translated the code to R for the ‘R Snippet’, where it ran without problems, however, due to the size of the data I would prefer to use the ‘Python Snippet (Labs)’ due to the by default Apache Arrow serialization.

Also important to note is that in the Python snippet I can actually see the output data as desired and the node executes successfully. When I want to view the output table the screen fixes at ‘Loading port content’. And when I use the data in further KNIME node I get the error code described earlier.

If anything is unclear, please let me know.

Error.knwf (988.8 KB)

Hi @n10_knime,

Welcome to the KNIME Forum! With KNIME 4.7.1 we fixed a bunch of issues with the columnar backend that arose with special tables created in Python. When a column had only missing values that would lead to very obscure problems (because the written arrow file would be corrupted). I could imagine that this problem is related (or even the same). However, I would need a workflow that reproduces the issue to verify that.

Could you please try your workflow with 4.7.1 and let me know if the issue is still present?


hello @bwilhelm,

Thanks for your response! My organization will switch soon to 4.7.1, then I’ll try! To be updated.


Dear @bwilhelm,

I updated KNIME to 4.7.1 now and installed the Python extension. Now when opening KNIME I get the following error:
KNIME_log_console.log (46.9 KB)

I tried restarting KNIME and switching workspaces, but that did not help. When I go to the Preferences to the KNIME Python to see the setting for this extensions, I get the following error:
KNIME_log_console.log (46.9 KB)
Is there something I can do to make it work?

Kind regards,


Hi @n10_knime,
I have not seen this error before. The root cause is that the plugin “org.knime.python2” could not be loaded because the extension point “org.knime.python2.serializationlibrary” could not be found. The plugin “org.knime.python2” is an essential part of the Python integration which is why nothing works afterward.
However, I am puzzled how you could end up in this state. The eclipse framework takes care of the extension points and the extension point “org.knime.python2.serializationlibrary” is not special and is defined by the same plugin (it must be available).

Did you have any issues updating KNIME AP? Could you take a look at the “Installation Details” (Help → About KNIME Analytics Platform → Installation Details) and see if there is anything suspicious there? (e.g. a feature or plugin by “org.knime” which has a version different from 4.7.x).

1 Like

hello @bwilhelm,
I found out that more in my organization or facing this issue and it is already being investigated by our IT and KNIME.

1 Like

Did you found a soloution? Im having the same trouble.
“Execute failed: Last batch index is 826, but maximum batch index is 360.”

@n10_knime can you check where your knime software is installed. The location of the log file seems to be in some sort of download folder. While knime can run in any place you do Hebrew full rights or might be that your organisation is blocking additional scripts like Python to be run from folders like download. Maybe try to use a fresh installation in another folder.

Concerning performance with large datasets you might want to explore these articles

Hi @andresgd7,

Which version of KNIME AP are you using? As mentioned in my first answer:

If the error still happens with 4.7.1 or higher it would be nice if you could provide a minimal example workflow that reproduces the issue.

1 Like

4.7.2. At the end i pass everything to python. Have a lot of problems with this node

Could you be specific? Which problems do you have exactly? At which end do you pass what to which Python?

And could you provide a workflow so that we can reproduce the issue?


1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.