Can't use Node Repository search on Kubuntu 18.04

Was able to use since this Friday the search field in the Node Repository using 4.7.2.
Today installed a bunch of new extensions, noticed clicking on the search field nothing happens, typing anyway a new text field opened on the lower part of the Node Repo window with the text but nothing is filtered.
The same happens selecting other windows such as Workflow Coach or KNIME Explorer, typing a text field appear. The KNIME Explorer search filed work as supposed.
Really annoying considering the number of nodes the search is fundamental.
Already tried to restart some times.

Could you provide a GIF of you doing this? If not, could you clarify what you mean by ‘clicking on the search field nothing happens’ (like: no cursor appears, no focus is denoted, ?)
Could you provide a screen shot of this text widget being added to the Node Repo and the Workflow Coach and the KNIME Explorer?

Also, what desktop environment are you using (e.g GNOME?)

Is there anything in the logs that looks like an error message with a time stamp around the time you are trying this?

(You mean 3.7.2, ya?)

1 Like

Thanks for your answer. 3.7.2 of course.
Attached a gif, same is for the other windows.
Clicking on the search field nothing happens, no focus, no blinking cursor.
Using KDE desktop. Was working Friday (modified my original post).
No errors, only these messages

WARN  TipsAndNewsInjector             Could not modify intro page: connect timed out
WARN  NewReleaseMessageInjector            Could not modify intro page:

Hmm - that is indeed weird. Are you using multiple monitors? If so, is KNIME running on the non-primary monitor? Do you remember which extensions you installed today?

If you quit KNIME, then go into your workspace directory on the filesystem and delete .metadata/knime/knime.log and .metadata/.log, then run KNIME, repeat the problem with the Node Repo search box (clicking the search text field, then entering text in the weird text field and waiting a few seconds), then quit KNIME again - is there anything error-ish to be seen in either of those log files?

Using a single Ultra Wide monitor.
I can check tomorrow for the other elements, almost midnight here so the PC I’m working with is off :slight_smile:

Discovered the arcane: for some reason the search field work only if I click on the right of it between the text field and the View menu triangle. A bit weird but glad there is a workaround.

1 Like

It is indeed very strange that the mouse down detection moved after new extensions were installed… :- /

I’m glad you’ve found a workaround though - thank you for updating the thread with it.

Yesterday clicked all around the text field and worked a couple of times, but was not able to discover the rule. Today was immediately clear.
Friday was working perfectly normal, so definitely some extension need to have made some change.
Need to verify the reporting system, the extension didn’t appear in the list but the manual is in the directory, so something was wrong during the installation.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.