Column Header - Edit

Do I have an option to bold my column header so that when i extract it in excel - the column header will be in bold

Hi @suseearun

Actually you can use continental node to edit it. Please refer to those examples for further helps.

2 Likes

Hi @suseearun , I’ve put together a quick demo of my XLSX Simple Excel Format Apply component.

If you install the Continental Nodes extension, you can use this component without knowledge of how to use the Continental Nodes themselves. The component will do it all for you, for the type of basic formatting you are looking for.

It can handle basic colour settings, and font sizes, and also formatting of dates and numerics,
e.g.
image

2 Likes

Thank you I am installing Continental node extentions now. I wanna try this so badly


It throws error

Hi @suseearun , that’s odd. What version of KNIME are you using?

Can I just check, did you restart KNIME after installing the Continental nodes, (before downloading the demo workflow)?

I have tried this on a different machine running KNIME 5.2.4 without problem (it gave load warnings because it was saved with KNIME 5.2.5, but it worked ok). I would suggest restarting KNIME and then re-downloading the workflow.

The error message is a bit odd, because there is an internal component “XLS Control Table Auto Tag Generator” (#660), as mentioned in the message, but as far as I can tell, there is no “Component Output” (#122), and everything is joined up correctly on my copy, so maybe something didn’t download quite correctly for you. I’m clutching at straws because I see no reason why it should be different for you. We’ll find a solution though! :wink:

hi @suseearun ,

I managed to reproduce the error on a fresh install of KNIME 5.2.4, that didn’t have the Continental Nodes installed on it.

So, I would say the solution is as I have suggested above → Make sure continental nodes are fully installed, restart KNIME and then re-download the demo workflow - Note don’t attempt to use the already-downloaded version since it will almost certainly now be irreparably “broken” as links will have been lost because nodes weren’t available when it was downloaded.

Yes. Node is working now.
I tried to copy the node into my workflow and tried to configure it.

But in the configuration ‘Heading Text’ and ‘Heading Background’ shows no option.

But in your workflow I can see a dropdown with lots of action

Hi @suseearun , as it’s a component and the config is dynamically generated, you need to exit the config, then execute the component and then reconfigure it. It is unfortunately just the way such components work.

For a brief discussion on this subject see this…

I was able to execute this for single sheet. Now I have 6 sheets in excel writer. I need the column header Bold in all the sheets

If possible, Could you help me configure a component for this requirement?

Hi @suseearun ,

If you have multiple sheets e.g.

image

The component should by default attempt to apply the selected formatting to all of them.


It throws this error

Can you show a screenshot of the configuration for the component?

I can generate that error if the Excel Writer is not configured to generate a path variable, in which case the component is unable to find one. Could that be the problem?



The above is the configuration page for the xls component.

The below is the configuration for excel writer

In the Excel Writer, click the [V] button

and create a path variable.
image

Then re-execute the Excel Writer, and you should then be able to select the path variable in the top of the component config

image

That should fix the problem.

it throws new error

My inclination here would be to reset the component (e.g. press F8) , and then try re-execute and see if that clears the issue. It’s difficult to tell remotely what that error is, because it isn’t something I’ve seen with the component before, so it’s either something that will resolve itself by resetting the component, or something unusual in the data it is trying to apply formatting to.

If that doesn’t work, could you try downloading a second copy of the component and attach it to the Excel Writer and try executing that, just in case something got broken behind the scenes.

I’ve run out of time for today as I need to be somewhere, so I’ll pick up again tomorrow if still no joy,

1 Like

Hi @suseearun , did you try downloading a second copy of the component, and attaching it to your Excel Writer and executing it ? Did the problem still occur?

As I have no way to reproduce the error you are seeing, if you are still having problems, please upload a workflow containing the configured XLSX Simple Excel Format Apply component, and an anonymized version of the spreadsheet that is being passed to the component. It is important that what you upload actually exhibits the problem, so that I can take a look to see if I can track down the cause.

Simple XLSX Excel Format Component Demo (2).knwf (758.8 KB)

Hi @suseearun , this is indeed strange. This looks like the component on that workflow has a corrupted configuration stored, as internally there is a KNIME node that isn’t returning the correct values.

If I try to execute it in the workflow, it fails as you have shown. However, if I then open the config on the component and then click apply, and then execute it again it works ok.

This is a video of the above showing the strange behaviour
https://www.dropbox.com/scl/fi/hs10qf51v6j5pbh8y4de9/2024-06-26_12-38-41.mkv?rlkey=uzytqxd6zdmp7yl4pjb6a6d5g&st=4baukypx&dl=0

I don’t know why it behaving that way. I’ve not seen it do that before, so I am hoping this is a one-off. It feels like a bug in KNIME, but as I say, it could simply be some sort of corruption that has occurred which is resolved by re-applying the config. You shouldn’t normally have to do this!

I hope this works for you. As previously suggested, it is also resolve by bringing a new copy of the component down from the hub, and removing the old component from the workflow.