Create and execute jobs fails the first time after server startup


Regarding the previous issue which was solved, now we are experiencing another one:
Now we are using the orchestration workflow to run the workflows but when we start the server the Post Request node which creates the job fails the first time we run the workflow but works fine next times. When I run the workflow as a remote job on server, I can reset the node and re-execute it and it works fine the second time. The error I get the first time I execute the node is:
415 Unsupported Media Type

So I tested the Post Request node to call on of our endpoints (not KNIME Server ones) and it works. So it seems the issue is from the KNIME Server. The strange thing here is that after I run the other Post Request node, the original node also works.

We are using KNIME Server Medium for AWS.
KNIME Server version: 4.12.2
Executor version: 4.3.2



To those who may encounter the same issue:
There is a workaround to make the node be re-executed after the failure:


Hi Armin,
Could you please check the setting of the canonical address within the knime-server.config?
Is this already set to use localhost?
Which address is used within the POST Request node, also localhost?

Hi @MichaelRespondek ,

The default is set to server IP. We use the server address provided in workflow API definition.
I changed both to localhost and still get the same error message.


Another helpful things would be to provide the logs files for the time/date when this occurs. Within the webportal you can pull the logs for the specific date and provide those, either here, or you can submit them to

From the logs we should be able to understand what the server side applications are doing during that time.

No records get added to the server logs after this error. It’s a single line record mentioning the error message in executor logs.