DB Connector to teradata not working

hello, I’m creating a DB conector to a teradata database, when I try acces, knime shows this error

ERROR Database Connector (legacy) 3:1 Execute failed: Could not create connection to database: Driver “com.teradata.jdbc.TeraDriver” does not accept URL: jdbc:Teradata://XX.XX.XXX.X:XXXX/XXX_XXX_XXXX

in theory the url is right.

have any one a posible solution.

Kind regards

Edgar

Hello @Fercho73,

and welcome to KNIME Community!

I suggest to use new(er) database connector node and not legacy. Also check this topic regarding Teradata connection string:

Additionally you can always check documentation:
https://docs.knime.com/latest/db_extension_guide/index.html#connector_generic

Hope this helps!

Br,
Ivan

1 Like

Add the current Teradata JDBC driver to your Preferences/KNIME/Databases config (NOT legacy) as database type “default”.

Then, use the DB/Connection/DB Connector node (NOT Database(legacy)). Database Type “Default”, Dialect SQL-92, and pick your Teradata driver ID.

URL - jdbc:teradata://

JDBC parameters - set parameter name DATABASE equal to your desired root database context. Set any additional driver parameters required (ENCRYPTDATA, TMODE, etc.)

Under the Advanced tab, set Append JDBC parameter to URL, JDBC URL initial parameter separator to “/”, and JDBC URL parameter separator to “,”. Enable all dialect capabilities.