Drag and Drop

Good day to both @takbb and @iCFO , since you mentioned using Windows OS and had no issues with the drag-n-drop, I’d like to ask if I’m doing the correct thing here:

Here’s how I’m trying to drag a component from the hub to a workflow:

In that video, I showed two ways: dragging side by side and dragging to a minimized window.

And here’s me trying to drag and drop a 16x16 image to a component’s icon section:

In this video, I also showed the 2 ways of dragging.

As you can observe, I failed in all trials. :cowboy_hat_face: Any insights on this matter is much appreciated!


What version of KNIME are you using, and what OS? I think drag and drop kicked in around KNIME AP v4.0

Edit - Nevermind about the KNIME version. I read 4.6.3 off of the info on your video.

Do you have all of the available software sites checked under preferences?

What happens if you go to view and show the “KNIME hub” window within KNIME AP, and then try to drag and drop? Does it work then?


Hi @badger101 ,

It looks like you are doing the right thing.

With the icon being dropped onto the component you need to drop it on the “Drag and Drop” dot-bordered region rather than on the coloured icon square, but I think you were trying that at one point. Difficult to be sure.

Certainly dragging the component from the hub you should drag it and drop onto the workflow area which is what you appear to be doing.

Are you able to drag and drop ok generally in explorer and other applications?

Are you by any chance running either Chrome, or Windows as an administrator?

1 Like

@takbb In the 2nd video, on the timestamp 0:25 you’ll see that I targeted at the right section, although a few seconds prior I didn’t.

Are you by any chance running either Chrome, or Windows as an administrator?

I am running all apps as admin.

@iCFO Thank you so much for the suggestion to drag from the Hub window within the AP itself. It worked! I would make a new vid to demonstrate that it worked but am too lazy to record and upload at the time being. But yes it did work!

However, that also points to the fact that the issue somehow is caused by dragging between two different apps, meaning that I can’t solve the component icon issue.

Glad to hear it is at least working for you. Did you try making sure that Chrome isn’t running as Admin like @takbb suggested? That has a decent shot at fixing the cross app drag and drop.

1 Like

Oh I should run it as non admin instead? At the moment, I’m running as admin for all apps.

Update: I just attempted something I found on the net and rebooted my laptop. Will update here the result.

1 Like

Okay, the update is a mix of good & bad news.

Let me first address that when I mentioned earlier that I ran as admin, I was referring to the fact that I have full system access (since I’m the owner of the laptop) and there’s no other user accounts than me.

My Chrome properties show that I have (presumably) ‘full control’:

Anyways, I went ahead and literally ran Chrome as admin by right clicking on it and choosing the admin option.

Lo and behold, I tested the dragging from the hub, and was shocked that it worked! I can now drag any component from Chrome without issues :grin:

That’s the good news. Now, the bad news is that it still didn’t solve the dragging of the image to the component. Which perplexed me.

Remember I mentioned also that I tested something I found from the net? One possible fix I found was to change the registry values from 4 to 50, which I did:

That didn’t fix anything though, after rebooting. :sweat_smile:

This was taken from → this blog post here ← specifically Method 5. There are 13 methods altogether but I wonder if I should try each of them.

1 Like

I don’t think that I have ever actually tried the drag and drop function for a component image…

If you deem it worthwhile to dive down the rabbit hole of fixing drag and drop on the OS side as well, then I would probably start with re-starting File Explorer. Leave the registry adjustments as a last resort.

Other thoughts.
Do you use a 3rd party clipboard manager?

Have you tried dragging and dropping a file out in the open on your desktop?

Perhaps a security or virus protection issue?

Maybe try it after a Safe Mode reboot? That will reduce the number of running program drivers to see if one is causing a conflict.

Do you use a 3rd party mouse software? Do you have a second mouse to test?

1 Like

Hi @badger101 , I think if you are an admin, it simply gives you the privilege to run something as admin, but does not run the app as admin by default (though I could be wrong). So, you are not necessarily running these apps as admin as you would think.

Security-wise, it’s actually recommended not to run apps as admin, so I would imagine that is why they do not run as admin by default, unless specifically chosen to.

I run on Windows too, and I don’t have any problem dragging and dropping components from the hub to my workflow (I just tried again). Similarly for dragging and dropping an image for a component, it works too without any issue. Been working all the time for me, and even on the 4.6.x (and previous versions from 4.2.x)

BTW, is the image file that you are dragging a png file? I can’t see the file extension anywhere. It only accepts png files.

EDIT: Also, I would recommend not to play with registry, especially if you don’t know what these do. In your case, if anything, you probably would want it to be lower. The DragHeight and width’s values indicate the minimum amount of pixels that you need to drag something for it to move/copy. Usually to set it to higher to avoid any accidental drag/drop. The default 4 means you have to drag something at least 4 pixels away in order to do a drag/drop. But setting it to 50, it means that you need to drag/drop between a larger distance (50 pixels vs 4 pixels), which did not make sense for your issue.


Interesting that the drag and drop worked in Chrome when running with the admin option.

I was actually expecting the opposite and my reason for asking if you were running as admin was that I’d seen mention elsewhere that running Chrome as administrator could potentially disable drag and drop. Although I’m not convinced there is a direct relationship as it works for me either way.

For you it appears the other way round though. If you now run Chrome without “run as administrator” does your ability to stay and drop now remain or does it do working again? As @bruno29a says, I wouldn’t recommend running as administrator generally and you shouldn’t need to, for drag and drop to work.

We will get to the bottom of this but it may take some time!


Thank you @iCFO @bruno29a @takbb ,

I just logged in for today, and I will reply to each of you soon. But first & foremost, here’s a summary of what I had done last night (before your new replies came in):

  1. From the blog link I was referring to, regarding the 13 methods, I have managed to proceed with all of the 13 ways, with a couple exceptions that concerns device drivers and device troubleshooting, both of which didn’t feel relevant for me to try.

  2. Here’s a screenshot of one of the many methods:

  1. The last method I tried before I went to sleep was this:


But it stucked forever at that point, so I decided to discontinue.

  1. So, for today, what I’ll do is:

i) I’ll record and upload the latest update about the success I had yesterday regarding the Chrome dragging issue, and also the failure of the Component icon issue.

ii) I’ll then come back to the forum to share the new video link and to reply to each of your new points.

Be right back!


@bruno29a and @takbb , to your point regarding the image format & running as admin, here’s my latest video addressing those:

The first thing I showed is the image properties (type and size) - this is the same image I used in yesterday’s. I then showed a failure of dragging the image to the component icon section. Following that, I showed my failed attempt in dragging a Component from Chrome. I then finished the video by showing a successful dragging of a component between Chrome & Knime when ran as admin.

@iCFO Here are my pointers:

I tried that too, but it didn’t solve the issue.

Yes, just after reading that. I was able to transfer any files to the desktop by drag-and-drop.

I’m not sure what you meant by a 3rd party software for a mouse. But the drag-and-drop issue persisted in both cases for my mouse and my touchpad.

I have always put Knime as an exception to Win Defender. But just to test out a security issue, I removed Knime from the exclusion list and ran a quick security scan of 42 seconds. I have no warning issued whatsoever.

Nope. I’ve never used one.

Here’s where it got really interesting, and hence why I’m putting this part in my last section. Here’s the detail:

  1. Running Knime in Safe Mode (F4) gave me this error:

  1. Running Knime in Safe Mode (F5) was a success. Also, to my surprise, I was able to drag and drop! Here are the screenshots:

I would appreciate if you or anyone could share ideas as to why it was a success, because finding out that ‘why’ factor might allow me to replicate that success in a normal windows mode. I hate the UI in the Safe Mode.

Also, this might be out of topic, but why can’t I access my Wifi network under the Safe Mode F5, when F5 should work differently than F4?

Many thanks to all !

Hi @badger101 ,

I think there’s an option that allows you to have network support in Safe Mode. The F4 F5 is not standard anymore it would seem, they seem to vary depending on the Bios (mostly per manufacturer) nowadays, so can’t really rely on them.

The “UI” should allow you to move up or down through the options.

The reason why things work in Safe Mode is because Safe Mode loads only the bare minimum. If it worked in Safe Mode, then it probably means that something is interfering when everything is loaded in normal mode. It could even be some drivers, since in Safe Mode, some drivers are not loaded.

It is usually a pain to try to figure out what’s causing this issue. Normally in this situation, I would disable everything in my startup and re-enable some at a time. Ideally you want to re-enable 1 by 1, but keep in mind that you require a restart to apply the change, so 1 at a time can take quite a while - I usually understand what most of them do, so that is why I can do a few at a time.

Other options that can be done is to restore your windows at a previous restore point. WARNING though, this could mean losing other changes that you may want to keep that were applied after that restore point.

1 Like

Also FYI - I was not able to drag and drop into KNIME between minimized windows by going through the taskbar until I did the most recent Windows 11 (22H2) update. Drag and drop into KNIME required that both windows be split and visible on screen in order to work. After the most recent update I can now drag and drop moving through the taskbar the way you attempted several of the times in your video.

I would definitely make sure you have installed all of your OS updates first before settings adjustments.

A good spot to start with an initial test is always antivirus / windows security settings as well. Just do a quick disable, test drag and drop and then enable it again to see if it works. Depending on your anti-virus software, you can sometimes just add a program to a trusted list to fix quirks like this.


@takbb @iCFO @bruno29a

Many thanks to all, but I have found the solution that fixes both issues concurrently. Previously, I didn’t do the UAC alteration by registry. Once I’ve changed the registry value from 1 to 0, I can drag and drop freely without running as admin or without going into safe mode. Killed two birds with one stone!

I tested this with both my mouse and touchpad. I have also reversed the other methods to ensure that the effect comes only from this fix.

Really appreciate all the help! :raising_hand_man:


Awesome! Glad you were able to solve it.

1 Like

That’s good news. Glad those dragons :wink: can be dropped once more!

1 Like

Hi @badger101 , I’m glad you figured it out, and thank you for sharing the solution, though I’m not sure why you need to change the UAC to be able to drag and drop.

Disabling UAC does have some consequences. It’s a security feature to protect your computer against changes being made without approval. By disabling it, you won’t be prompt for approval for any changes that an app (or a virus) is applying to your computer, and malicious changes can get applied without you knowing.

UAC should not prevent you from doing drag and drops, unless if you are dragging from non-admin to admin (you can’t drag to higher privileged app).

This could be a hint that you might be running knime as admin, which is not recommended. Another hint is that you were able to drag from Chrome to Knime when you ran Chrome as admin (you can drag from admin to admin).

Similarly when you tried to drag an image into Knime for the Component, it did not allow you, because most probably you’re running Knime as admin.

I think if you run Knime as non-admin, you should be able to drag into Knime. This would also allow you to re-enable UAC (ideally you want this to stay enabled)


Thank you @bruno29a ,

If by running Knime as an admin, you mean right clicking and choosing to literally run as admin, then no, that wasn’t the case.

By default, too, my Knime doesn’t run as admin:

Because that wasn’t the case, what I did to check on the different privileges was that I compared the info from the Security tabs (in Properties) from both source (the folder containing the icon image) and destination (Knime). From here onwards, I’ll refer to them as ‘source’ and ‘destination’ for the sake of simplicity.

What I found was that the ‘destination’ had one Special privilege that the ‘source’ didn’t:

My thought was to remove this special privileges with the hope that the drag-and-drop from ‘source’ to ‘destination’ will be between similar levels of authorization. So, in order to remove that Special privilege, Windows prompted me to disable inheritance first. I was then able to continue with the removal.

The only difference between the source and the destination now is the additional ‘Interactive’ user:

Apart from that, for the rest of the ‘users’ , each of them has similar control settings on the ‘Allow’ sections. (EDIT: Now after looking at my own screenshots, I also see additional allowance such as ‘List folder contents’.)

Do you have any ideas on what to do going forward? Given that removing the Special permissions didn’t solve the issue. And I didn’t remove the INTERACTIVE ‘user’ since I don’t know what the effect on my Knime use would be. I don’t even know what it is or how it got there. With regards to the Special permissions, I can always reverse the decision by adding it again. (The Special permissions removed was regarding the ability to DELETE).

Hi @badger101, it does feel like @bruno29a might be on to something but the whole admin/non-admin/uac thing does feel odd nonetheless.

I wonder if it might be worth doing a second installation of KNIME on your pc, by downloading one of the zip file versions of the install (rather than the “installer”). Just unzip to a totally separate folder outside of Program Files or wherever, and run the knime.exe file contained within it. Then see if that version behaves itself with UAC switched back on. I’ve currently got 3 different versions of knime installed side-by-side in this way (each with its own workspace).

Another thought… what folder do you have KNIME installed in, and what folder are you using for it’s workspace? I remember having an issue with an installation of firefox some years ago that fired a UAC prompt at me almost every time it started up because it was doing (yet another) update. I finally figured that for whatever reason, during installation, something had caused it to install itself in a way that made windows think it was an elevated application. Uninstalling and re-installing somewhere different fixed the issue.

Also… how to check if a specific application is running with elevated permissions, using task manager:

1 Like