Error in Batch-Modus: Execute failed: Cannot determine ID of local mountpoint

I am using KNIME v4.7.3.v202305100921 install on a Ubuntu 22.04.2 LTS System
since the last Update I get an error when I call Sub-Workflows in Batch-mode. In the Forum, some one posted that the problem is solved by using the “Mountpoint Connector”:

I tried this but it failed. Now the “Mountpoint Connector” raises the error. Other in the mentioned post I can not use a fixed local path, since my workflow is used on different machines.

When I execute the workflow within KNIME, everything works fine.

As a workaround I tried to use within the mountpoint connector a string-variable, which I hand over in batch-mode. If I execute the workflow in batch-mode, this value is used, otherwise (Execution within KNIME Frontend) the standard mountpoint connector (Current mountpoint; Set working directory to the current workflow checked) is used. This works fine, but I have to call Workflows from “Call Workflow (Row Based)” where I can only handover string values in JSON. So as a work around: is it possible to get the full path out of the “Mountpoint Connector” file system connection if I do not hand over the current mountpoint in batch modus (execute from within the KNIME-Frontend)?


Hi @Matthias_W ,

I had the same problem few months ago, and it’s solve when I reinstall de application and update the nodes (some of them were obsolete).

To create a full path, you can use the string manipulation to join the “knime.workspace” flow variable with the path from mointpoint.


And put it into a flow variable or append column.

Then you can use it to find and use as the “original/solid path”. It works for me.

Tks, Denis

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.