Execute failed: Java heap space

Hi everyone,

I read relevant posts related to this topic but I cannot find knime.imi to change -Xmx.

My problem is that I want to use Write to Excel Template Note with around 400k rows data but it showed me that problem. However, when using Excel Write only, I worked.

Note that I am using company resources and I downloaded KNIME from Workspace ONE Intelligence Hub.

Should I ask the administrator for that?

Hello @huynhduc,

if you don’t have KNIME configuration file under “C:\Program Files\KNIME” (Windows here) or it’s not editable then you should contact administrator for any change.

Additionally you can try a different approach:

  • use Excel Writer node with Append option that will add data to existing Excel file (sheet) - not sure does this preserves formatting completely and is a bit cumbersome because you have to create a copy of template before you write to. Latter is under assumption it’s automated process and you will have to output data from Excel regularly
  • use Excel Writer to write data to new Excel file and then Continental nodes to format newly created Excel - this is approach I take and works pretty well I must say

Hope this helps!


Hi @ipazin

I’ve heard about Continental nodes but recently, I can not see the node to download it, through the hub:

Like, the icon, I cant see the icon of this node or something to drag and drop.

Hi @huynhduc , on that web page you should see an icon here…

On your question of locating your KNIME.INI, if your KNIME is installed somewhere other than the Program Files folder (e.g. if it had been installed from zip archive), you can drop the following component onto a workflow and execute it. It should attempt to open your knime.ini file in your system editor:


Thanks @takbb and @ipazin ,

Maybe I need to ask the admin for this :rofl:


1 Like

And for the continental node,

I tried before and thought that was wrong due to this.

I click next multiple times but it’s still there, nothing change.

But, when I check, it showed that I installed already.

However, I can’t find it anywhere by searching “Continental”.

Hi @huynhduc , try searching for “xls” rather than Continental, since they don’t have continental in the name.

If you still can’t see them, click the filter button on the top of that node panel

and on the window that then displays, make sure it is set to show all nodes rather than “starter” nodes

1 Like

Perfect @takbb

But is there any article or example that I can follow to use those nodes please?

Should it be used at the end of the workflow like this? Excel Writer and then those continental nodes applied?


There is a bit of a learning curve to them @huynhduc , but take a look at this related post, and also see the links to other posts at the bottom.

It seems though that some of the original documentation I have referenced in the past has either disappeared or moved! :frowning:

Pinging @Continental_KNIME_Extension_Developer - do you know where your detailed tutorial/documentation has gone. The link I previously had was this:


It has been referenced elsewhere and appeared like this:

but that now just goes to a generic community/extensions page :thinking:

Meanwhile, there is a free ebook

and there is a small section at the end that discusses formatting with the Continental nodes.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.