Favorite Node Adder error/bug

I hit an issue with KNIME AP today and I see that something similar to this (I think it looks related) appeared before in the forum:

In my case, I was looking at a forum post this morning concerning “Active Learning Loop End”, and I opened a new workflow to experiment…

When I added the Active Learning Loop End node (it was the first node I added), the following error occurred:


Any attempt to add any further nodes to this, or any other workflow (even with this workflow closed) resulted in the same error. (I should add that the nodes did appear to get successfully added to the workflow each time, in spite of the error message)

The full log message for the error is this:

	at org.knime.workbench.ui.favorites.FavoriteNodesManager$CopyingCategory.addChild(FavoriteNodesManager.java:315)
	at org.knime.workbench.repository.model.AbstractContainerObject.addAllChildren(AbstractContainerObject.java:193)
	at org.knime.workbench.ui.favorites.FavoriteNodesManager.updateLastUsedNodes(FavoriteNodesManager.java:205)
	at org.knime.workbench.ui.favorites.FavoriteNodesManager.updateNodes(FavoriteNodesManager.java:195)
	at org.knime.workbench.ui.favorites.FavoritesView.nodeAdded(FavoritesView.java:228)
	at org.knime.workbench.repository.NodeUsageRegistry.notifyListener(NodeUsageRegistry.java:117)
	at org.knime.workbench.repository.NodeUsageRegistry.access$0(NodeUsageRegistry.java:114)
	at org.knime.workbench.repository.NodeUsageRegistry$1.run(NodeUsageRegistry.java:193)
	at org.eclipse.core.internal.jobs.Worker.run(Worker.java:63)

My environment is: KNIME AP 4.3.3 on Windows 10
BootLoader constants: OS=win32, ARCH=x86_64, WS=win32, NL=en_GB
Command-line arguments: -os win32 -ws win32 -arch x86_64 -data file:/F:/brian/KnimeProjects/

I restarted KNIME and the problem went away, until I added either an Active Learning Loop Start or an Active Learning Loop End node, at which point exactly the same occurred again, and any further nodes being added once again resulted in the same error.

For whatever reason the issue appears to be that the Favorite Node panel cannot add either of these nodes to the Last used nodes list. Once it has hit this issue, I’d say that any further attempts to add to the favorites history while it is an inconsistent state during this session fails.

On restarting, while other nodes showed on that panel if they had been added prior to the error occurring, neither of the Active Learning Loop nodes appear there, and no node that was added after the error started to occur, appeared on the panel. The error itself was cleared by a restart, and then new nodes being added to the workflow appear on the “Favorite Nodes” panel again.

Further, I found that I could avoid restarting KNIME and clear the error by simply pressing the clear history button on the favorite nodes panel. So that presumably resets the state of the “history” object(s). (And of course I lost the info gathered by Favorite Nodes)


I’ve not seen this error when adding any other nodes, and not had reason to use the Active Learning Loop nodes before.

I’m presuming that others are not seeing this issue with these nodes, or it would surely be mentioned more, yet for me it is consistent that an attempt to add either of these nodes to a workflow results in the error. I wonder what makes them special in my environment. Any ideas appreciated.

It’s not urgent to me as I am not actually using these nodes, but it would be nice to know the answer anyway, just in case I do want to use them at some point, or it is indicative of something else being incorrect in my environment.


The problem persists on my Win 10 box. It happens for long node names.

thanks @izaychik63 , that’s interesting. Does it consistently happen for you? I looked at some of the other available nodes, and there are many with longer names than these that don’t seem to cause the problem for me, or do you mean the length of an internal name, rather than the name I see in the Node Repository?

I’ll create an internal ticket for a developer to look into. So far, I couldn’t pin it to anything specific (such as name length).
Did this issue come up with any nodes besides the Active Learning Loop Start/End nodes?

Hi @marvin.kickuth, thanks for this. I tried out quite a few other nodes of varying names lengths, that I’d not used before but only the nodes mentioned appeared to cause the issue for me.

1 Like

Please see my post on the topic

Hi @takbb

we found the issue (it does only concern those two nodes, though the issue is quite technical, so I’ll spare you the details) and are delivering a quick-fix to make it into version 4.4 :slight_smile:

Kind regards


This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.