File creation date cannot be conserved for connected remote file system

Dear KNIME team,
I need to preserve the date creation and date modified parameters from files that were loaded via file transfer node from a remote location. But it seems that at least one of the parameters is changed by the operation of file transfer. Looks also a bit as if my operation system is confusing date created and date modified (see the attached images).
The creation date and time of the files are really important for me since I am using this to associate the file with additional meta information. Do you have any idea how this can be solved? Could both dates be conserved? Is it a problem of the operation system?
Thanks for ideas and help in advance.

I tried a few additional options, copying also files to the share with the option of preserving the time stamp. It appears also to be dependent from where the files are copied, whether they are copied from a hard drive or another share. When copied from a hard drive the correct creation/modified date is shown with the file meta info node. When copying it from another share there is a mismatch between the properties of dates as given in windows explorer and what is shown by the file meta info not. I do not understand this at all, there must be some hidden information. I also tried programs such as RichCopy and TotalCommander to preserve folder and file saving dates/times…but does not work.

I made additional investigations. For some files the file meta node is not obtaining the correct creation/modified dates, for reasons I do not understand. If I use the node locally, i.e. not via the folder share option, the correct date is given.
I tried to obtain the information via an alternative way, using a “get reqest node” as was described earlier here, however I struggled with the syntax of the files on the shared network folder so that I can access it via get request. I tried the following syntax:
With an URL starting with file:///// I could access the file using a browser, but “file:///” does not seem to be allowed for get request nodes.
Thanks in advance.

Hi @sscholz

this looks odd indeed. Also if you check the dates on your screenshot. It seems the file was modified before it was created.
Do you know if one of the parent folders has been renamed or if you have shortcuts that you look at or the original files?


1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.