File reader loop - Varying columns each time, force all to string

Hi Folks,
I’m using the file reader node as part of a loop to read in CSV files. I read the first file and it works as i’ll let it scan the table to associate the columns types. I require all columns to be read in as string (usually 2000-5000 columns).
Along comes the next file in the loop it has an extra few hundred columns, rather than scanning the file it will set some of the columns to doubles, when in fact they should be string, and the node fails once a string comes along.
How can I force the file reader or a file reading facility to always read all columns as string? I can do this by setting the cell_class in the variable columns properties as string, but the next file that comes along has more columns which also need set, again failing the flow.
Is there a way of doing this dynamically for varying number of columns for each loop iteration?

Hi there,

this topic can help: Force KNIME to Read CSV Columns As Strings



This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.