Generic JavaScript View error due to high number of rows?


I am facing the following error when trying to process several JS views in a single component:


In this specific example, I have 3 JS view of around 40k rows each. The views work correctly individually. However, when I open the view the whole component with the 3 views combined, I always get an error.

Not sure how to proceed? Is there a known limitation regarding the number of rows allowed to be processed in the JS node?

And yes, the value in the node configuration is already set to more than 40k.


Thank you.

Hi misterhd,

Does this problem occur when you have only 2 of the JS views combined in a component?

I’ll look into any known limitations regarding a max number of rows being processed in components / JS nodes.


Hi Kyle_Watkins,

Exactly. The views work correctly individually.
However when I combine 2~3 in a component I get such error.


We might be able to debug this better if you enabled the debugging interface in the javascript view by adding these lines at the end of your knime.ini file:
This file lives in the same directory as your knime.exe installation on windows.

It seems like this issue is happening due to a timeout (which makes sense due to the high volume of data). In that same knime.ini file you could try changing the following argument to -1 to remove a default timeout.

Hi Kyle_Watkins,

Thanks for the feedback. I have been able to apply the changes to the .ini file but I am still facing the issue. This is the error that appears in debugging mode:

require.js:5 Uncaught Error: Load timeout for modules: js-lib/plotly/1.47.4/plotly.min.js
Common Errors
at makeError (require.js:5)
at l (require.js:5)
at require.js:5

It does seem to be the case the timeout is due to the plotly dependency, which is the one I am using in my node.


However, I don’t really know how to change this timeout. Any sugestion?

Thank you.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.