Help with displaying different language characters.

Hello Everyone; I still haven’t found a viable solution to the problem I encountered before. And unfortunately I encountered something similar.

I need a permanent solution for this issue. Because I collect data from every source in the world, I have to work with every language in the world. But there is a problem of displaying languages in knime.

It’s the same issue as the issue I opened earlier. I can’t display south korean language.

example web page : 사업공모·입찰 > 입찰공고 > 입찰공고 > 목록

I wanted to open a topic open to all solutions. I hope we can find a definitive and guaranteed solution. Because I think it is a general problem that many people may encounter.

@umutcankurt maybe @LukasS can weight in about the ticket “AP-17532”. I think typically if an issue is resolved a note will be posted under the original thread

Only other thing I could think about would try to use some Python node. I could see if this makes a difference but the problem within KNIME would still remain.

2 Likes

Hi @umutcankurt and @mlauber71 ,

just added a +1 under AP-17532. One more thing you might use until this is fixed: the characters are displayed correctly with the Node Monitor for me (Windows 10):

Kind regards,
Lukas

1 Like

Hang on, we dug a little deeper and found a solution:


(well, not “we”, but @marvin.kickuth, so kudos to him)

The technical issue seems to be that Java Swing on Windows 10, which is responsible for the Node dialogs and also the Table view, goes through all installed language packs instead of doing what the Node Monitor does. So the solution was for me to install the “Korean Supplemental Fonts”. This can be done like so:


(windows restart required)

So if you want to be prepared for all languages there are, you might want to search for “font” in the additional features and install all of these.

Cheers,
Lukas

4 Likes

Hi Lukas
I tried to install in windows many times without success. I even tried the solutions described in this topic, which is a very common problem, and it still didn’t work. Windows installation fails midway.

Do you know of a solution where I can manually download and upload the file that you would suggest to me. ?

I tried to add AP-17532 but the add button is not active. I changed the spelling and it still didn’t work.

Hi @umutcankurt ,

I tried searching “windows 10 install supplemental fonts” on the web and according some of the results the fonts do not need to be downloaded but they ship with windows, so “only” an installation is needed. What happens if you follow the steps 1. - 6. as per my screenshot? It took a little while for the installation (~10min) for me and apparently takes ~250MB of disk space for all fonts. After that I had to restart the computer and I had the Korean font available in KNIME.
(this is me giving windows support; fingers crossed this actually works :crossed_fingers:) Maybe this is a resource that you might have luck with? Other than that, do you maybe have an IT department at hand that could help you out there? Is there a download needed after all and a firewall/antivirus blocks something?

“AP-17532” is our internal reference for the bug related to the missing fonts in KNIME. I just posted the ticket number so that we can reference it - there’s nothing you need to (or can) do with it other than finding them in the changelogs every now and then :slight_smile:

Kind regards,
Lukas

1 Like

@LukasS Thanks for all your replies and support. A second thank you for your genuine concern and time
:wink: :+1:

1 Like

@umutcankurt it might be possible you would need admin rights to install these fonts.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.