How to edit file to change the memory

I added the XLS Cell Formatter to my workflow so I could wrap the data which I believe the wrap option is the same as wrap text in Excel. When I execute the XLS Formatter (apply) node workflow I am getting a execute failed: Java heap space error.
I did some reading in the forum and it was recommended to change the memory to write table to disc.
I did that and it didn’t work. The only other option I read was to edit the KNIME.IN file. How would I go about doing that or is there another option I should explore first.

Your .ini file should look mostly like this:

algebraic:~ loki$ more /Applications/KNIME\ 
algebraic:~ loki$ 

The line you’re interested in is the one starting -Xmx - in the above example it is allocating 2048MB. You can use either m or g in your specification (to denote MB or GB.)


This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.