javax.mail.AuthenticationFailedException

#1

Hi,

I’m trying to sent the email at local level the workflow is working well , but when i run the job from the server I ve got this error

javax.mail.AuthenticationFailedException

Any Idea what could be ?

Gianpoalo

0 Likes

#2

Hi,

what do you mean with ‘at local level’? Do you use a locally installed mail server to send the mail to user@localhost?

Do you get also a log with the error, indicating where exactly it ocurred?

Cheers,
Moritz

0 Likes

#3

Hi ,

local i means when i run the workflow from my local Machine , in that case it works fine.

when i run the same job from the server the workflow fails .

Basically only the node “send Email” is not working

image

0 Likes

#4

Hi,

what kind of mail server did you use? Could it be that this server is not reachable from your KNIME Server/Executor (e.g. a firewall that blocks the connection)?
Maybe a specific port is blocked.

Cheers,
Moritz

0 Likes

#5

I’m facing exactly same issue. I’m using Gmail server to send mail.
How can I check the KNIME server for a firewall block/Gmail server is reachable or not?

Regards,
Vipul Phulphagar

0 Likes

#6

Hi,

does the Send Mail node work on your local machine?

Cheers,
Moritz

0 Likes

#7

Hi @moritz.heine,
Yes it does work and I successfully get the mail

Thank you,
Vipul

0 Likes

#8

@vipul, do you get any error messages? Or does the node execute normally but not send the mail?

Cheers,
Moritz

0 Likes

#9

Hi Moritz,
Actually, I was using the same Gmail account in the Client workflow as in the WebPortal. However, it was failing in the WebPortal but executing successfully in the workflow execution. I had already turned on “Allow Less Secure Apps” on my Gmail account.

While trying on WebPortal, I again tried to turn on/off the “Allow Less Secure Apps” to allow KNIME to communicate with Gmail’s SMTP server. And later it worked on WebPortal too.

I couldn’t understand why it didn’t work in the WebPortal in the first instance as KNIME was allowed that time too.

But anyway, it’s working!!.

Thanks a lot for your quick help :slight_smile:

3 Likes

#10

Hi,

thanks for your update and solution!
One question though, what KNIME Server and Analytics Platform versions do you use? Maybe something has changed in the backend how we identify ourselves to Google (e.g. another key or so), but I would have to ask another developer.

Cheers,
Moritz

0 Likes

#11

Hi Moritz,
KNIME Analytics Platform - v4
KNIME Server - v4.8.2

Cheers,
Vipul

1 Like

#12

Hi,

KNIME Server v4.8 runs with a KNIME Analytics Platform 3.7 as an executor so it could be that Google also checks the version number (or something similar). I will investigate further.

Cheers,
Moritz

1 Like

#13

Hi @geppopompo ,

does your problem still remain? If so, could you provide further info that Moritz has askes about?

Cheers,
Mischa

0 Likes