javax.mail.AuthenticationFailedException - Send email issue on Server

Hi there

I have an issue where the Send email node works on AP but not when deployed to Server. I am using the Gmail settings, and tried with:

  1. with the username/password embedded in the node,
  2. the Credentials manager
  3. Credentials Configuration node to pass username and password
  • but it just doesn’t work through the Server.

Some other posts corrected this by turning the Google ‘Allow less secure apps’ off and on again (https://hotter.io/docs/email-accounts/secure-app-gmail/) - but this also did not work for me.

Any ideas would be appreciated!

Send Email 3:92
Execute failed: Error while communicating with the smtp server: javax.mail.AuthenticationFailedException

Related Forum post:

Hi @supersharp,

good job, you have already tested all possible solutions that are mentioned in your case. Could you please provide the server logs, I will have a look at the specific error? You can download them on the web portal/Administration panel logged in as a KNIME admin. I will send you a PM how to provide the file.

Best,
Michael

Hi @MichaelRespondek

Actually I managed to figure this out with the help of a KNIME team member.

I am documenting the solution below for anyone else experiencing the problem - note, this was a GMAIL specific setup:

  • Send Email node worked in AP but not in Server, using Gmail email credentials
  • There are several things to make the Send Email node work for Gmail in Server:
  1. Allow “less secure” apps - https://support.google.com/accounts/answer/6010255?hl=en
  2. Log into your Google account - account.google.com
  3. Go to Security
  4. Go to Signing in to Google
    Here you must set 2 things:
    a. Set-up 2-step verification. This will either make you verify through a mobile or other method
    b. Set-up an App Password. This will generate a new password for you - specific to use with an external app. It should look like this:

  1. Next, go to the KNIME workflow, use the Credentials configuration node to feed the Send Email node - but use the Google App Password instead of the regular email password!

image

This setup should work with both AP and Server!
If there is any issue with running on Server then double check Server Execution Options - potentially the App password will need to be entered here too:

image

Hope this helps someone else facing this challenge.

Now, to figure out the Microsoft Exchange and Yahoo sending methods :slight_smile:

6 Likes

Thanks @supersharp for the great and detailed explanation. I thought this would only the preferred method if the two factor authorization is already active. :+1:

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.