KNIME 5.2 run problem ...

Dear Knimers, after I decided to completely switch to the new version of Knime (5.2) and after I uninstalled the old one (4.7), I got stuck in the inability to start (load) the program with message saying that I have to look in configuration file which one I can not understand - what I am doing wrong?
image
1701878522401.log (652.6 KB)

I forgot to mention earlier: I tried with the previous version (5.1.2) and it works fine, but when I upgrade to version 5.2 from version 5.1.2, I got a similar message (my first post) … I’m using Windows 11.
Thanks for help
Stjepan

Hi @ssimara -

Thanks for the log and description of the problem. I’ve asked internally to see what might be going on. Sorry for the trouble!

Thanks Scott, I’m willy looking forward for solution! - hope it will be in reasonable time, I mean, 5.2 it seams like true step and I will like to be with in my work as soon as possible!

Hi @ssimara -

So based on what I heard back, it’s likely that this is a Java version problem. In your log, it shows

java.version=1.8.0_391

But KNIME ships with its own version of Java, which is specified in the knime.ini file:

-vm
plugins/org.knime.binary.jre.win32.x86_64_17.0.5.20221116/jre/bin/server/jvm.dll

Can you check your knime.ini file to make sure that it matches the above? You might also try upgrading the pre-existing Java version itself.

1 Like

Thanks Scott, here is -vm line in my ini file:
-vm
plugins/org.knime.binary.jre.win32.x86_64_17.0.5.20221116/jre/bin/server/jvm.dll

Question: which version of JRE do I need then? … as far as I know, I already have the latest version of JRE, I mean: 1.8.0_391 (as Java Control Panel say to me on my update tab) … should I then uninstall java machine first and then install new version of Knime?

I would try uninstalling the conflicting version first. Can you give that a shot and report back?

Hi Scott, thanks for response. I did try next steps - I do not know if is a kind of solution probably - but it works for me know:

  1. uninstalling JRE first
  2. install fresh KNIME copy but then I get following message:
    image
  3. I reinstalll JRE again but than very known error is coming back whan I try to lounch KNIME app, said: I have to see log file in configuration folder which I already send to you earlier …
  4. deinstalling JRE again …
  5. create new Path variable in my Windows Environmental variables point to javaw.exe in KNIME plugin folder …
  6. deinstalling and than reinstall fresh KNIME copy …
  7. Launch KNIME and now everything looks fine!!

So, my question is: why I can not have JRE platform install onside together with JRE which came with KNIME installation? and why is that in my case KNIME installation procedure can not recognized his own path to javaw.exe file - I need to manually create environment variable path first?

Glad you were able to get there! As for the details of why it worked, I’d need to ask internally again and find a Java expert. Sorry I’m not more immediately helpful.

Same problem here. I used a fresh user install (tried both options, only for me and with admin rights) of Knime 5.2 installer on Windows 11. I don’t have any extra jre/jdk installs. I also verified the jre.dll path is correct in knime.ini.

Previous Knime 5.1.2 installer works fine. Any ideas? Thank you!

image

Hi @mbloechle ,

If you navigate in Windows Explorer to the

c:\users\mb\Local\Programs\KNIME\jre\bin

folder do you see the javaw.exe file there?

Is that folder actually present?

if you open a command prompt in Windows and type in the command:

where javaw

what result does it return?

I see you have VS code on the path. What do you see if you type:

where code

Hi @takbb, there is no such jre Folder in C:\Users\mb\AppData\Local\Programs\KNIME

Thank you!

Best regards, Max

Hi, any ideas or update on this @ScottF? Thank you!

Hi @mbloechle -

What does the -vm line in your knime.ini look like, and does a matching JRE exist at that location?

Hi @ScottF, thanks. The line points to an existing jvm.dll with 12234 KB (when I change the forward slashes to backward slashes).

Since this is a vanilla install using the installer, I would assume this to be correct. Is there anything else I can check? The knime.log does not contain anything recent.

-vm
plugins/org.knime.binary.jre.win32.x86_64_17.0.5.20221116/jre/bin/server/jvm.dll