KNIME not opening/starting/responding


When I start my KNIME, it seemed stuck somewhere and it does not open. (See the attachment). I have no idea why. I used it last week and it was working perfectly. Any idea why this is happening and suggestions on how to solve it?





I have encountered a similar problem with KNIME stalling indefinitely during loading.  I was able to resolve the problem by force quitting KNIME, and then deleting the workbench.xml file, which is located inside your workspace folder in <workspace> \.metadata\.plugins\org.eclipse.ui.workbench.  KNIME will then open properly though your windows will be in the default locations.

This is the result of a bug involving the location of the windows in the application.  (I’ve confirmed that this is a bug with the KNIME team.)  You can avoid the problem by clicking on the KNIME Explorer tab immediately before exiting KNIME. 

If this doesn’t work, you could try the more drastic measure of deleting (or renaming) the entire .metadata folder.  You will lose all your saved preferences, but at least KNIME will open and you will have access to your workflows.

Hope this helps.



I had the same problem with KNIME 2.11.x that it got stuck during the start of the workbench. I deleted the file workbench.xml  in the directory \.metadata\.plugins\org.eclipse.ui.workbench and now it works again.

What I have seen so far is that the tree in the workflow directory is completely expanded. That is no problem for me.

Can anyone explain the impact of this deletion on the overall installation? Will I loose "something"?




Hi all

Just updated to Version 5.3. (version 6th of dec 17) and have the same problem.

after clicking on the exe file it remains in the starting screen, the loading bar is not visualized. waited over an hour, but nothing happened.

tried all the solutions in your comments above, unfortunately nothings works.

also did the "cold restart" recommended in the summary of the release (Additional notes about the 3.5 release).

any ideas?

thanks manuel

Hi Manuel,

can you provide some information regarding your operating system? Can you try a reinstall of KNIME 3.5 from the website and see if it works with the current workspace?

Sorry for the trouble,


Ciao Christian

I reinstalled everything from scratch and it work fine now. Would have been more convenient not to reconfigure everything, but it wasn't a big effort, so all ok again.

Thanks for your help


Hi Manuel,

glad to hear that it works now. Could tell us which operating system you are using? This would help us investigating what the problem has been in the first place.




Same problem here after the update.


I have Windows 7 Home Premium

Hi there,

I am experiencing same issue with version 3.7.1.

It does not help deleting metadata file neither. It takes appr. 10 minutes to start. Do you have any idea to solve it?


Did you update to 3.7.1 from another version from within KNIME or download the 3.7.1 application from the web site?

Which operating system?

After quitting KNIME, delete the .metadata directory, run KNIME, and after startup has completed, does your .metadata/knime/knime.log have any messages about Exceptions?

log.txt (26.3 KB)


and it opened after 5’14’’. Log file is attached.

Program is running on Windows 10 64 bit OS.

As I mentioned, deleting metadata directory does not help.


Hi, this seems to be the kind of log messages i would expect to see in .metadata/.log as opposed to .metadata/knime/knime.log - could you attach your knime.log ?

(I wasn’t suggesting that you delete the metadata directory as a panacea, but to avoid having a lot of confusing logging information - it would be most helpful to have the logs of exactly one long app startup.)

knime_log.txt (486.2 KB)

I believe I hava clue on this.
another subject in forum gave me the idea. When I de-activate my IT defender software, Knime starts faster. But apparently, Knime needs an internet access to start.


Good that you found the post about avoiding the scanning of KNIME’s jars by your antivirus software.

While KNIME does use the internet (looking for software updates, news updates, workflow coach suggestions, remote KNIME servers, … etc.) it shouldn’t “need” it to start - indeed i just turned off my network interface and KNIME 3.7.1 started up in under 10s. What are you seeing that causes you to say it needs the internet?

My mistake… I thought my corporate’s IT software has nothing to do with offline duties on OS, so judged it might not have any role on lag of KNIME start-up while disconnected.

As I tried offline and the sw de-activated, KNIME started up in 30 seconds. The IT sw seems the only responsible for lag.