KNIME Server - Selenium License Issues

Good afternoon KNIMErs

I have a trial Selenium License key with a view to using a number of fully licensed keys on my companies KNIME server.

I am unable to get the Executor on our KNIME Server to recognise the license for selenium nodes.

I have successfully installed the nodes to the server.

And when a failed job is opened from my dev machine via KNIME AP I get the following error:

I have opened the GUI on the server, logged in as the user which runs the KNIME Executor Service, and installed the necessary nodes and license.

I have then exported them to the desktop and identified the following preferences:

/instance/com.nodepit.licensing.plugin/ws.palladian.nodes.selenium.plugin=-----BEGIN LICENSE----- \r\n\r\n\r\n\r\nyOkBAb8CQP3EDQMBCAFAFoJMJ241+AHLeHUAZBNKoWRlc2NyaXB0aW9uPWFs [REDACTED] \r\n\r\nmX2Kfk2p7PzJzHTKsMqUH1kI4uJy9x4Onv2+z2DEW/dtmiSTQZA= \r\n\r\n=8FvC \r\n\r\n-----END LICENSE-----

/instance/ws.palladian.nodes.selenium.plugin/ws.palladian.nodes.selenium.didRunMigrateLicenseKey2=true

@ws.palladian.nodes.selenium.plugin=4.12.2.202303142030

These preferences have then been inserted into the following file.

knime-server-repository/config/client-profiles/executor/executor.epf

I have then amended the ini file: knime-executor/knime.ini

-profileLocation
hypertexttransferprotocal://127.0.0.1:8080/WebPortal-Context-ROOT/rest/v4/profiles/contents
-profileList
executor

I have then restarted the service, restarted the machine. I have also deleted the service and created a new one by calling

knime-executor/remove-executor-as-service.bat

Amending knime-executor/install-executor-as-service.bat to include:

SET “KNIME_EXECUTOR_PROFILES=-profileLocation http://127.0.0.1:8080/WebPortal-Context-ROOT/rest/v4/profiles/contents -profileList executor”

Then executed knime-executor/install-executor-as-service.bat and set the login for the service to knime-service-user@acompanyname.co.uk

Have I missed anything obvious?

We are running in a windows environment and have Server 4.15 installed with a KNIME Executor version of 4.6.1

When I open the GUI on the server I can happily create/execute/save/amend workflows with your nodes. It is only when they are executed by the KNIME Executor Service I run into the issue.

Many thanks

Frank

p.s. Just one more thing …

I have also found this blog which may be something similar to my issue, but it seems the solution was in a private email.

Hi Frank,

I’m simultaneously in contact via email with Dave about the same topic, and I strongly assume you’re from the same team, am I correct? :slight_smile:

I am replying here rather than via email, as the preferences configuration on the KNIME Server unfortunately often causes big troubles, confusions, and frustrations for our clients and I’d like to have this topic visible to the public (and the KNIME company).

@ KNIME forum administrations: With that in mind, I think it makes sense to move this back into the “KNIME Server” category where it was originally created, as it is a KNIME Server configuration issue and not specific to the Selenium license.

Based on the steps you highlighted in the email, I do not see any obvious issues. Yet I can recommend to have look at this thread (never mind that it’s talking about “Palladian license” - the principle is the same):

Note that the file paths mentioned in this thread are different to the ones you mentioned in the email, so I guess it’s worth double-checking.

Unfortunately the user didn’t provide any details back then - it was rather a trial and error (similar to the thread linked above).

Independently from that, I have another suggestion for a workaround - let me get back about that later here!

Thanks,
Philipp

/offtopic
I had a strong suspicion that you are getting notified whenever a topic is created in “your” subboard so I moved it there :smile: Is back to server now.
//offtopic

1 Like

Point taken - thanks for that :slight_smile: :+1:

Hello qqilihq

Indeed Dave is my colleague.

We have looked through the forum link you suggested and have the following to note:

we did this

We followed all the advice given by NDeKay. Part of his advice was
image
we have tried it with and without

we also double triple checked our file paths

we also tried what sebversailles did

unfortunately, none of these attempts worked

Do you have another way forward?

Frank

Hi Frank,

thanks for the update - I hope that the KNIME Server support will be able to assist you with properly setting up the preferences.

In the meantime, I can provide the following workaround, which is not ideal, but which should hopefully help to get your workflows running on the server. The workflow contains a single meta node called “Input Selenium License Key” - please copy this node to your own workflow, open the configuration and paste your own license key. Ensure that it is executed when running the workflow on the server. It will then simply set the license key upon workflow execution (instead of taking it from the preferences):

Download the workflow from my NodePit Space:

Hope this helps for now - please keep me posted :slight_smile:

Best,
Philipp

5 Likes

Hello qqilihq

amazing, works a treat, thank you.

For others who might be reading this post in the future. I had to make one small adjustment to the component.
Open the Component.
Configure the Java Edit Variable
image
Go to Additional Bundles Tab


Click the red line “com.nodepit.lic …” and press Remove Selected Bundles
In the highlighted field start typing “com.nodepit.l” and your version on com.nodepit.licensing.plugin will appear

Add Selected Bundles
Apply, OK
Voila!

Many Thanks

Frank

4 Likes

Hi Frank,

great - glad that this helped to fix it, and many thanks for the feedback. This way I have a workaround to present in the future :slight_smile:

Fur any further questions let me know - here on the forum or via email.

Best,
Philipp

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.