L4-DL Image Classification Exercise Error

Hi together,
I have the same problem. I tried to change the configuration. Always the same problem/error
‘The index 5 exceeds the size of the feature dimension 1.’.

THX, Ralf

Hi @ralf42 -

Did you try changing the conversion type as posted in my screenshot in the other thread?

Hi @ScottF, i can not try the conversion typ above, it’s not in the list of possible selections.

Best, Ralf


In that case can you upload your workflow so that someone can take a deeper look at the problem? It’s very hard to do detailed troubleshooting with just screenshots.

It’s an example-workflow from a L4-Deep Learning webinar.

THX, Ralf

Image_Classification_MNIST_Solution.knwf (703.7 KB)

Hi @ralf42 -

I made a new topic for your question to avoid confusion, since I realized the other topic was about a different workflow.

I verified that this workflow fails with the same error on my machine, even with a fresh download from the Hub. I’m not sure why that is; let me ask internally and I’ll get back to you.


Hi @ScottF,
I took part in the webinar on version 5 today. That looks very good! When version 5.1 will be released in summer, will a keras integration also be included? And is there anything new about my error message?


Hi @ralf42 -

I believe so, yes. We are in the process of updating extensions to work with KNIME 5.1.

Nothing new to report on your error, sorry about that. I mentioned it to one of our course instructors. I’ll see if I can follow up again.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.