Lost significant amount of nodes after "save as" used (v5.2)


I’m a new KNIME user and have liked it so far. However, I recently lost a significant amount of work because of a file save issue. This could be me misunderstanding workflow/ file saving protocol, but I haven’t experienced this in similar software. I save many backups while developing workflows to avoid this type of issue.

What is strange is that the “save as” changed the name of the folder successfully and the .svg file saved with an image of all nodes that were added in the workflow. However, the nodes that were added no longer appear in the folders or in the KNIME workflow file upon reopening. Any thoughts on how to restore or how to avoid this issue in the future? At this point, I’ve given up on troubleshooting on my own and I’m now using the .svg image that was updated as a guide to retrace my steps. Would love to be able to restore the workflow though- it was working great.

Thanks in advance for any assistance or insights!

1 Like

Hi @gbair10,

Sorry to hear that. Just to understand the issue better, would you explain the problem in more details please?
Did you try to “save as” the current workflow with a new name or did you try to overwrite an existing workflow? If latter, was the destination workflow still open?

1 Like

I think I have a similar problem as gbair10. The workflow does not save, (although save is allowed). Additionally all my nodes in the KNIME node repository are gone. Have lost hours already due to unsaved work and now cannot continue as all Nodes disappeared. New to KNIME, in principle love the product but I wonder how people work with all this instability. Thanks for any hint.


I have the same situation. I use ‘save as’ to be able to revert to previous ‘versions’ of my workflow.
So every ‘save as’ worked up to V17. Save as V18 resulted in a new folder including all data from V17 and an updated svg. I continued to work on V18 and saved the workflow multiple times. Now the V18 folder contains a svg including my work on V18 but the work itself is lost. The .artifacts folder also has todays date as change date, but the two JSON files in that folder are empty.
The folder is not protected by windows security. I’m on 5.2.0.v202311301336 using the “modern UI”.
If someone can point me to relevant log files or some other helpful stuff, I will be glad to provide further details. If there is a better approach to work with ‘versions’ please give me a hint :slight_smile:
Thanks in advance!

Hi @RobertGetzner,

Would you provide us a few things that could help to find the cause of the problem and fix it:

  • Would you select “Debug” for “Log file log level” in “preferences > KNIME” then try to reproduce the issue and after reproducing, share the knime.log (workspace/.metadata/knime/knime.log) file with us?
  • Can you reproduce the issue in 5.2.1 (the latest release) as well?

Have you tried your KNIME Community Hub Private/Public spaces? You can manage your workflows/components versioning conveniently. For example, if you have the first version of the workfllow uploaded, you can open the workflow in your AP and save the changes directly to your Hub space as a new draft. Then you can give the new draft a version and keep editing it as a new draft again. Give it a try and let me know if you have any questions.


sorry to hear you’re experiencing data loss here. We’ll investigate. First of all, we need to find a scenario to reproduce the issue so we can work on fixing it.

As Armin already pointed out, the first step would be to see if this is still an issue in 5.2.1.

If so, to find the log file, you can also directly navigate to it from the AP.


Further, if possible for you, could you navigate to Help (upper right corner) > Help > About KNIME Analytics Platform > Installation details and send a screenshot of the “Installed Software” tab? Please make sure that the contents of the “version” column are visible.


Is it possible for you to share the workflow you’ve been working with?


Hi @armingrudd,

enabled the logging, so far could not reproduce the problem. Didn’t know about 5.2.1 (wasn’t notified in AP?!), shall I rather update or wait if I can reproduce the problem in 5.2.0 ? Could it be related to “NXT-2316: Workflow SVG is empty if workflow is saved from within component” and/or "NXT-2211: “Save As” workflow not working properly (kudos to @sw1336 for reporting 1) " ?

Will have look at the hub, thanks!

Thanks for your support!
Best regards, Robert

1 Like

Hi @BenjaminMoser,
thanks for your support.

If you prefer, I’ll update to 5.2.1 and wait if it happens again, maybe I then know how to reproduce the problem.

Can’t upload the workflow, sorry. However it’s not complex as I’m a beginner. Components are “two-level” max (component-in-component), just a few flow variables. No loops.
I believe the last things I did (which were not saved) are additional output tables for components and adding rank and linear correlation nodes. Up to V17 “save as” went well.

Installed software:

Thanks and best regards, Robert

1 Like

Hm, unfortunate to hear you missed the update. We do have a notification in the modern UI (yellow bar at the bottom after startup) – but it only says “There are updates for k extensions available”. I think this can definitely improved to indicate when there’s an actual AP update available. I’ll raise that internally (NXT-2410).

Some logging is always done, Armin’s instructions only configure to log even more. Could you still provide us with the your log file? It’s possible something was logged when the issue occured and that would be very helpful.

In any case, if you’re not set on 5.2.0, I’d recommend updating to 5.2.1 – there are no breaking changes between bugfix releases and it makes it easier for us to troubleshoot your issue.

I don’t think your issue is related to NXT-2316 or NXT-2211.


I updated to 5.2.1. Will report in case the problem occurs again. Actually I saw the “extensions” update popup, but ignored it :wink:

log attached, had to shorten it…
knime - Kopie.log (2.2 MB)

1 Like


the workflow you’ve had the issue with wasn’t the “AutoML (Regression)” one, right?

The logs say there’s been no error loading v18 but as far as I can see (at least the excerpt you attached) does not go back to you working with v17.

If you’re so inclined, you could send me the logs going back farther, maybe something is reported there w.r.t not being able to save v17 or v18 properly. If you don’t want to share it publicly, you can also email me at benjamin.moser@knime.com.

Apart from that, as long as we cannot reproduce the issue, we unfortunately don’t have much to go on.

Regarding your earlier question about how to work with versions – we’re currently working on introducing the concept of versioning to our products. As Armin has indicated, this is already a thing on the Hub. Integration into the Modern UI is still on our To-Do-List.

Apart from that, if you want to work fully locally, you could also use a version control system like Git – that’s a bit more technical though.



This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.