Math Formula (Multi Column) not working to move 0 to Null

Hello Community,
I would like to remove all 0 from my Dateset and make it to a missing Value (?).

The reason why my dateset even has zeros is because of a GroupBy function which counted the elements. But, this zero in the dataset make it hard for me to use a “Missing Value Column Filter”.

Math Formula works, but only for one Column:

When I try to use the Multi Column formula, nothing works:

I tried using it without the if because I noticed that something does not work.
The Columns are included in the block:

Does someone have an Idea, what I should change for making this operation work?
I am totally open to use a different approach to make the 0 to a ? In my dataset. I only don’t want to use a loop because it is 100 Column and needs some time. There should be a smarter way in handling this approach.

Thank you to everyone looking on my little challenge :slight_smile:
Greetings Alex

If you’re going to show a screenshot of configuration window, you should show the whole window so that we can see how things are configured. These partial views aren’t very helpful.

When I try to use the Multi Column formula, nothing works:

What exactly do you mean when you say “nothing works”?
What does the input KNIME table look like?
How is the Math Formula (Multi Column) node configured?
Why is the formula here different from the one you showed earlier in the Math Formula node?
What does the output KNIME table look like?

For reference, it works as expected for me:




@elsamuel Thank you very much. I fund my mistake, but it is really a stupid one!
The Configuration Windows for the Math Formula (Multi Column) has a scrolling bar on my computer. I can not see the bottom where it says append or replace. Append was selected, therefore, because of many columns, I did not see the transformed ones.

Everything worked since the beginning, I only did not configured it properly :face_exhaling:

Thank you so much for the feedback!
Greetings Alex


If it makes you feel better, I once thought I found a bug with the String Manip Multi Column, but it turned out that if I had noticed that there was a scroll bar, I would’ve found additional features of the node.

So you’re not alone :cowboy_hat_face:

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.