Microsoft Authentication - Interactive login not working correctly

I’m on Knime 4.4.0.v202106280851 using Power BI Integration 4.4.0.v202106241409.

The node I’m using is the “Microsoft Authentication” using the “Interactive authentication” feature because my organization does not use any other mode.

When I try to login via this way the node errors out with the below message about the “Address already in use”:

ERROR Microsoft Authentication 0:1 Address already in use: bin

Can anyone help here? I’m guessing the node will need some update or have a dynamic allocation of the port used?

Thanks in advance!

Hi @datanumbers , this is going to be extremely hard to reproduce.

It’s a network issue where the connection did not close properly, and the port is in a TIME_WAIT state. It should clear once it times out, so if you try again in a few minutes, it should be ok.

I’m not sure if this type of incident should be handled by Knime - it depends on how this was implemented.

Thanks for looking at it, I do think that the port allocation should be dynamic or let the user to change it to avoid this.

I don’t think its a time_wait at all as such wouldn’t persist through several reboots and several hours (in my case its still blocked)… So this is something else alltogether. Anyone know what port its trying to bind to?

I also agree, I’m frustrated that this is not getting the attention it needs to. Hopefully we can raise this even further.

Hello @datanumbers,

reset/restore to defaults seems to help out @jguidera in this topic:

Maybe same could work for you? (Think I have seen same approach helped recently someone else with another issue but can’t find topic now…)



Hey thanks for looking at this one, I tried that but no luck, I still get the

Address already in use: bind

I also reset my proxy settings from browser but nothing. Here are my Network settings for reference: