No connect to ms sql server by windows authentication

I have installed the KNIME extensions seen here: KNIME Database Extension Guide

  • KNIME Microsoft JDBC Driver…

But I cannot make a connect with the parameter “integratedSecurity=true” to use my windows session.

I get always an domain error:

ERROR Microsoft SQL Server Connector 0:1 Execute failed: Anmeldefehler. Die Anmeldung stammt aus einer nicht vertrauenswürdigen Domäne und kann mit der Windows-Authentifizierung nicht verwendet werden.

Hi @m_amann and welcome to the Knime Community.

Can you show us how you are using the Connector? Can you show us the settings you are using?

For using your windows credentials to connect to MSSQL, you should use the None/native authentication option for Authentication:
image

For integratedSecurity, if it’s needed, you can add it as a JDBC parameter like this:
image

Click on the Add button, and it will allow you to add an entry. Just add integratedSecurity as Name and true as Value

There is a Microsoft SQL Server Connector node specific for SQL Server. Have you use this?

Hi @Daniel_Weikert , based on the error message “ERROR Microsoft SQL Server Connector 0:1”, the request is using the Microsoft SQL Server Connector node. If it was any other node, say the DB Connector node, the error message would have been “ERROR DB Connector 0:1

Hi @bruno29a , good point, guess I forgot to put my glasses on, sorry for that.

1 Like

Hello together, thank you very much for your respone. I have made this settings so as shown here, but it doesn’t work. Further I must say, that the SQL Server has a installation of multi instances. This instances I can address for example in ODBC-System-DSN by (DNS)-computer name like “xy.abc.local/[database name]” or only by computer name, but then the port name of the running instance. In KNIME I think I can only use the possibility with port number.

image

If I use username and password, then it works. But this would be not my favorite solution.

image

I have found a solution which does working with “integratedSecurity”. I use the “DB Connector”.

There I can set the SQL-Server like:

jdbc:sqlserver://[server name][instance name];DatabaseName=[database name]

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.