No content to map due to end-of-input REST API result, but working in POSTMAN


I am using the GET request node to retrieve data from a REST API.
However the result is ,?" for a ,bigger" data.
When I add the Extract Missing Value Cause node, the result will be the following:

How can I retrieve the full data from the REST API?
When I test the same API in POSTMAN it works fine…
(Also, I am using NTLM auth, just a note)

Knime version: 4.3

Hi HordosBence,

I cannot help with the GET node, but maybe you want to have a look at the HTTP Retriever from Palladian as a robust alternative:

For any questions with the Palladian HTTP nodes feel free to get in touch in the dedicated sub forum!




I already tried it, but forgot to mention, the REST API is using NTLM auth.
I could not configure this auth in the Palladian nodes…


True – we currently do not support this, sorry! :slight_smile:

Hi @HordosBence , the GET Request seems to support NTLM as Labs version:

Give it a try

Hey @bruno29a ,

As I said earlier, I forgot to mention, that I am using NTLM auth in the GET request node.
In the first post, you can see that I am using the GET Request node, it’s configured to NTLM auth.

Hi @HordosBence , sorry for missing that.

I’m not sure what else you can try.

I have no way to test that (at least I do not know a website for that) but maybe you can use a python snippet for that

sth like

import requests
from requests_ntlm2 import HttpNtlmAuth

requests.get("", auth=auth)


1 Like

Hello @HordosBence,

same API as discussed here?

Have you tried increasing timeout?


1 Like

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.