"No such node ID: 0" error while executing a workflow in server

Hey there, I am a beginner and currently exploring the functionalities of Community nodes, Chemistry nodes and CDD.
Situation -

  1. I created a simple workflow which retrieves the data associated with the saved search in my Vault in CDD and then manipulating the data the way I want.
  2. The individual nodes in the workflow are executed successfully.
  3. I deploy the workflow in the server.
  4. Here, I get an error message **

" Error occurred while loading workflow into memory: An error occurred during the creation of a job for ‘/KNIME-CDD/CDD Connect Test1’: No such node ID: 0 "


Not sure if I am missing something really silly.
Need help!

Hi @pandasas,

Did you install the CDD extension/node also on the Server? It seems that the Server has issues to find the node definition for node #0 which is the CDD Export in your case.



I have gotten the that a lot also, but if I check reset workflow before upload I don’t get it, so you can try that.

Skärmavbild 2020-03-09 kl. 15.49.28

1 Like

Hi @pandasas,

is your issue solved now? If not, we can provide further help on that.


Hi @MichaelRespondek

Yes, installing the node in the server solved the issue. Thanks!



This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.