OpenMS incompatibility with Generic Workflow Nodes 1.0.0

#1

Hi OpenMS Team,

I have currently installed the Generic Workflow Nodes in its latest version 1.0.0 from the Community Contributions Update Site for KNIME 4.0. Unfortunately, I am not able to install the latest version of the OpenMS Nodes from the same update site as they depend on Generic Workflow Nodes in version range [0.8.100,1.0.0).

Software being installed: Generic Workflow Nodes for KNIME 1.0.0.v201907091326 (com.genericworkflownodes.knime.feature.feature.group 1.0.0.v201907091326)
 Software being installed: OpenMS 2.4.0.201810261314 (de.openms.feature.feature.group 2.4.0.201810261314)
 Only one of the following can be installed at once: 
  GenericKnimeNodes 1.0.0.v201906282022 (com.genericworkflownodes.knime 1.0.0.v201906282022)
  GenericKnimeNodes 0.8.100.v201906191249 (com.genericworkflownodes.knime 0.8.100.v201906191249)
 Cannot satisfy dependency:
  From: Generic Workflow Nodes for KNIME 1.0.0.v201907091326 (com.genericworkflownodes.knime.feature.feature.group 1.0.0.v201907091326)
  To: com.genericworkflownodes.knime [1.0.0.v201906282022]
 Cannot satisfy dependency:
  From: OpenMS 2.4.0.201810261314 (de.openms.feature.feature.group 2.4.0.201810261314)
  To: de.openms.knime.importers [0.0.1.201810021715]
 Cannot satisfy dependency:
  From: mzML importers 0.0.1.201810021715 (de.openms.knime.importers 0.0.1.201810021715)
  To: bundle com.genericworkflownodes.knime [0.8.100,1.0.0)

Are there any plans to get rid of the version limitation and make the OpenMS nodes compatible with the latest version of the Generic Workflow Nodes. Otherwise, latest at the point were new nodes dependent on Generic Workflow Nodes with version range [1.0.0,2.0.0), we have an either or situation.

Best regards,
Daniel

0 Likes

#2

Hi Daniel,

in theory it should be supported already. Some quick questions while I investigate the problem:

  • Was it on a fresh install of KNIME or did you “update” the plugins?
  • And it was the community 4.0 stable update site right?

Best,
Julianus

0 Likes

#3

Hi @jpfeuffer,

Thank you for having a look into this.

Yes. Fresh install with KNIME 4.0 from the stable community update site. The update site also contains the Generic Workflow Nodes in version 0.8 and 1.0. If I install only the OpenMS nodes everything works as expected (because they pull the Generic Workflow Nodes in version 0.8). In I already have installed the Generic Workflow Nodes in version 1.0, dependency can not be resolved anymore.

I had a quick look into your MANIFEST.MF files, and as expected it requires the old version of the generic nodes: com.genericworkflownodes.knime;bundle-version="[0.8.100,1.0.0):

Bundle-SymbolicName: de.openms.knime.importers;singleton:=true
Require-Bundle: org.knime.base;bundle-version="[3.0.0,5.0.0)",javax.ac
 tivation;bundle-version="1.1.0",com.genericworkflownodes.knime;bundle-version="[0.8.100,1.0.0)",org.apache.log4j;bundle-version="1.2.15",o
 rg.apache.commons.io;bundle-version="2.4.0",org.apache.commons.codec;
 bundle-version="1.6.0",org.slf4j.api;bundle-version="1.7.2"

Best regards,
Daniel

0 Likes

#4

Hi!

Ah yes. I found the error. Can you try it again?
Thanks for reporting.

Cheers,
Julianus

0 Likes

#5

Awesome. Just verified and everything works as expected! Thank you very much, @jpfeuffer!

Just realized, you are also working for the institute that develops the Seqan nodes. Do you mind giving your colleagues a quick heads-up to fix the pretty same issue on there end, too? Forum post is here: Seqan incompatibility with Generic Workflow Nodes 1.0.0

Best regards,
Daniel

0 Likes

closed #6

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.

0 Likes