OpenMS Prerequisite Installer shows "SSL Not enabled for this installer"

Hi,

I am using KNIME/OpenMS on Windows 10. I was having an error with a few of my nodes, showing an error code of -1073740791, with no other apparent output. I was able to track this down (through this forum question), and I need to install the OpenMS prerequisite installer for 2.7.0. I have verified I am using OpenMS 2.7.0.

When I tried to use the installer, I get an error code that says:

There has been an error.  
SSL support was not enabled for this installer
The application will exit now.

Does anyone happen to know why I am getting this error?

Thanks for any help!

I seem to have fixed my issue.

During the installation screen, there are a list of items:

Microsoft .NET 4 available: 1
Microsoft .NET 3.5 available: 0
VC runtime 10.0 x64 available: 0
VC runtime 10.0 x86 available: 1
VC runtime 14.0+ x64 available: 1

The items that have a 0 next to them are not installed. This may be different for your system!

My best guess is the installer does not try to use SSL when it connects to the Microsoft servers to download the required packages, and an error occurs. Download the required packages, and each line should have a 1 next to it. The installation continued without error once this was done.

I also had to reboot my computer for installation to take effect

EDIT: Despite thinking I had fixed the issue, I am still having the same problems described above

Hi!

Since you seem to be proficient with the Windows internals, you might
want to check the actual missing libraries by running DependencyWalker: GitHub - lucasg/Dependencies: A rewrite of the old legacy software "depends.exe" in C# for Windows devs to troubleshoot dll load dependencies issues.
on the affected executables in:
X:\ProgramFiles\KNIME…\plugins\de.openms.win64…\bin

Did you solve this problem? I have exactly the same error. Would be nice if you can share the solution if you found it.

Thanks,

Peter

We updated the installers:

Let us know if it works now. Don’t pay too much attention to the warnings in the KNIME log. It is very hard to check all potential registry entries for those dependencies. Just try and see if the nodes work without error.

Hi there, I am having the same problem as listed above and have tried this solution, it did not work on my PC.

Did anyone try the new installer?
Which problem do you have? The SSL problem of the installer or the node failure (exit code)?