OSM street layer

Hello. OSM Map View node only displays elevation map. Why can`t I see the street layer?


Captura de pantalla -2022-02-04 11-25-37

Hello @peleitor,

Thank your for your message and reaching out to the KNIME Forum. May I ask, which version of KNIME Analytics Platform you are running?

Best regards,

Hello @peleitor,

I wanted to come back to you with some information on the observed issue.

It should be possible for you to switch to a BiCycle Map - at least this is what we configured right now. In terms of the base map (Wikimedia Map), we observed limited functionality in the near past. Since Wikimedia limits how many tiles we can download from their servers per time unit, users would run into UI glitches where only a few tiles would be loaded and others remain empty. Hence, we removed the option for the Wikimedia Map, due to the fact that there is no proper way to bypass the described behavior.

We do understand that this is not satisfying. However, there might be a chance that we plan to work on an updated map viewer with a more modern library in the backend.

Best regards,

Thanks. How do I get and apply an api key in order to use BiCycle map? (and avoid the “API Key required” watermark)

I’m a little bit confused. When using the OSM Map View Node (without any parameters and input) I can see multiple different maps. These are the

  • Wikimedia Map
  • Cycle Map (with the api key information)
  • Bing (aerial pics) as in your pic
  • OpenTopoMap
  • Strava running heatmap

Only the OpenSeaMap is blank.
So it’s working well for me.

As mentioned I can’t confirm that.

My KNIME is a bit outdated (KNIME 4.3.0). Maybe some changes in the newer versions?

@knimediger @kevin_sturm thanks for your replies! It helped me to understand the changes made to KNIME in latest versions. I see you need to go to Preferences / Open Street Map, and there you see a list of available map source. Notice, however, that the list is a bit confusing: checkboxes are missing for many options (maybe my Gnome renderer? I’m using Linux Mint 20). The point is, I could successfully select Wikimedia Map, clicking on the corresponding map row to the left (where the checkbox should be).

Screenshot at 2022-02-12 08-45-33

1 Like

Thank you for this information.
But in KNIME 4.3.0 these settings do not exist. Good to know when I’m running an update.

Hello @peleitor and @knimediger,

Thank you for sharing your information and insights.
I can confirm that KNIME 4.3.0 still allows you to use the WikimediaMap to a certain degree. However, it did not seem to be the case for our newer releases, where our developers faced the issue of limited tile fetching capabilities of this provider more and more - which lead to the necessity of disabling this map provider.
@peleitor you are right. While going to Preferences > KNIME > Open Street Map you can enable e.g. OpenStreetMap (German Style), which then allows you to get a basic openstreetmap base map for your viewer node.

Best regards,

1 Like

This post could be related. Maybe the integration of kepler.gl could be a good and simple option.

Hello @szawadski,

Thank you for bringing kepler.gl to the table. I replied to your linked post regarding this.

Best regards,

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.