R Snippet and R Path Installation & Failure

I followed and confirmed steps 1 and 2 here KNIME Interactive R Statistics Integration Installation Guide , but I cannot get step 3 to work.

(Just updated to v 4.6.0 and just installed R per linked instructions.) Even tried a couple of restarts on my computer.

I tried several iterations (changing spacing, etc.) of R.home() per step three and can’t track anything on my hard drive related to R. I missed something on the install (windows). Suggestions? Thanks

temp1

Your path to your R Home directory is incorrect. Mine looks something like this:

C:\Program Files\R\R-4.1.2

Double check where you installed R on your system and make sure that’s the path you specify.

1 Like

Hi @ScottF thanks for responding. I can’t find it anywhere on my computer. I did all the knime installs, double checked and knime confirmed I had done so, but I don’t know where R got buried (checked all over my C drive, knime folders, program folders, etc). Since I can’t find it, I can’t uninstall it and try again. I’ll dig around some more. Thanks

1 Like

I finally got the base R connected to KNIME. Now I am getting several errors in the Console (red font). Do you know if I can find and download the required packages here (windows) Rtools42 for Windows

@creedsmith I think you will have to install the required packages in your R installation. Maybe try and use RStudio which makes it easier to handle such things.

Also you might want to familiarise yourself with the handling of KNIME and R in general.

If you absolutely need RTools to compile packages (which should not be necessary in general) there is this older entry about that.

Also there is this collection about KNIME and R you might explore. Some topics are somewhat special.

1 Like

Thanks @mlauber71 , I had installed R and Rtools yesterday, but still have the same errors. I will read through your links. Thanks

temp

1 Like