.Rprofile ignored?

Can it be that R-Snippet nodes ignore the .Rprofile in my Home-Directory?

If so, can anybody give me a hint on how I can get KNIME to use that file?

Thanks a lot,

Sebastian

This depends on your R configuration within KNIME. Please check the R executable that is configured in the KNIME preferences under R. If this is set to the pre-packaged R version that comes through our update site (only for Windows), you should change this path to your local R instance or copy the profile into this installation. You can also figure out the R_HOME value by running R<-Sys.getenv("R_HOME") in the R Snippet node.

Thanks gabriel for your reply.

It gave me the idea to run the following code inside an R-Snippet node:

R <- commandArgs()

When you do that, you can see that R is started with the option "--vanilla" meaning that R will ignore any profile files, regardless of environment variables etc.

Question to the KNIME developers: Is it possible to disable this?

Sebastian

I see your point and I already have had a look into it. The R Snippet and R View node always use this option whereby the other R nodes don't. We have added a arguments field to the R node dialog that allow to change the arguments for all R nodes starting with KNIME v2.5.1 that will be released very, very soon.