Run KNIME 4.3 in batch mode with preferences

Hello everyone,

We have an Knime 4.3 workflow that need to use the bigquery database plugin, but we need to configure the preferences

This works great if we use the KNIME UI to run the workflow. But if we use the batch mode like we do for several other workflows fails with error:

“ERROR main Node Loading model settings failed: Could not find the [bigqueryID] database driver”

Seems like we need to add the “-preferences” tag in the batch command to load the preferences, or they will be ignored.

We use that way, but don’t works:

c:/progra~1/knime/knime.exe -nosave -nosplash -reset -application -preferences=file.epf --launcher.suppressErrors org.knime.product.KNIME_BATCH_APPLICATION -workflowDir=“C:\knime-workspace\engag\web_traffic”

Thanks in advance for any help

1 Like

I still need help, when I run the below comand, Knime UI just opens and do nothing.

c:/progra~1/knime/knime.exe -nosave -nosplash -reset -application -preferences=file.epf --launcher.suppressErrors org.knime.product.KNIME_BATCH_APPLICATION -workflowDir=“C:\knime-workspace\engag\web_traffic”

I also get this warning:

WARN HadoopInitializer Unable to find ‘msvcr100.dll’ at hadoop home creation.

1 Like

I really need help with this :wave:

1 Like

It might be helpful to also print additional information

mlauber71 had an interesting comment there. Maybe there is some information you can use
batch mode

I tried to execute the batch mode myself yesterday to test but got a “3” error. (not fixed yet)
bR

1 Like

@Peter29 In your command, org.knime.product.KNIME_BATCH_APPLICATION is not at the right place. It must go right after -application.

–Philipp

2 Likes

Hi guys, many thanks for the help, seems its working that way:

c:/progra~1/knime/knime.exe -nosave -nosplash -reset --launcher.suppressErrors -preferences=“C:\App\task_batch\engag\preferences.epf” -application org.knime.product.KNIME_BATCH_APPLICATION -workflowDir=“C:\knime-workspace\engag\web_info”

Just a note: to generate first the “preferences.epf” file, you need to go in KNIME menu: File → Export Preferences

2 Likes

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.