screen size of KNIME

One of my students downloaded KNIME. She uses a Mac. Somehow the screensize was cut in half. I tried to go to view – reset perspective but it did not help. She uninstalled it and then re-installed it but it still remains the same. I wonder if anyone has suggestions. Thank you!

Try to close small panels and reopen them using View menue.

This has been seen before - discussed here: Grey Area in Knime Workflow Editor

We are not very close to understanding why this happens for some people at the moment :- /

So there is no solution yet?

Yes - to my knowledge, no one has reported back that they have solved this - and we have not been able to reproduce it ourselves (in order to have something on hand to determine the problem.) @matteast92, does this still affect you?

Thank you.

Hi, I can confirm that it is still an issue with me. However i don’t currently have need for Knime with my work so haven’t taken this forwards. I will let you know when i do!

I also experience the same problem. After installing KNIME 3.7.1 I enjoyed a full screen. After importing the first workflow, my screen is half gray. I don’t know what to do about it but it is very annoying especially when the workflow is big.

If you quit KNIME, then delete the file .metadata/.plugins/org.eclipse.e4.workbench/workbench.xmi in your workspace directory, then restart KNIME, it should restore the full screen; we still don’t know what causes this corruption.

(Also, if you’re running on Windows, make sure you are using 3.7.2 instead of 3.7.1, as 3.7.1 has potential application-hanging issues on Windows.)


This workaround works perfect :grinning:
Thanks for the very quick response!
I will ask IT to install the latest version of KNIME.

1 Like

I have the same problem on Windows 10 with just downloaded KNIME 4.2.1.

Hi @Soren,

welcome to KNIME Community!

Have you maybe managed to solve it with suggestions from above linked topic? Did half screen came after first start or after you installed some extensions and then restarted KNIME?


I just wanted to mention the same thing happens with the newest version. I was able to remove the file mentioned above and fix it. Yes, I downloaded KNIME and then installed some extensions. But I was not sure if the extensions got installed. Then the issue happened after restarting KNIME. Then I tried to reinstall KNIME and the same issue came up right away without installing any extension. I guess not all files are getting removed properly when uninstalling KNIME.

I just created my account to Thank You!!!


Hello there,

just to drop info that with version 4.3.2. this is addressed and half screen problem shouldn’t happen any more. (AP-16147)

If workspace already has this issue and is opened with 4.3.2 for the first time a simple restart will fix it.


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.