Selenium node 3.0 does not work on KNIME Server 4.7.2

Hi,

Our KNIME Servr installation:
KNIME Server : 4.7.2
KNIME Analytics Platform: 3.6.0

Our Workflow work with Selenium Node to get something from Internet , it work fine on KNIM Analytics Platform from Windows Platform and not work when we deploy it to ther KNIME Server, the error message as following:


WebDriver Factory (deprecated) 3:91 - ERROR: Execute failed: No license specified. Please obtain a license and enter it on the Selenium preference page in order to use the Selenium nodes.

Find Elements (deprecated) 3:104 - WARNING: Guessed input column: "WebDriver".

P.S.: Our Selenium License is valid before 2019/10/05.

Thanks.

Hi there,

on a KNIME Server, you’ll need to import the license key as described in FAQ#17.

Side note: please make sure that your license fits the conditions for being run on a server (the Selenium Nodes are licensed per user, so the number of licensed users needs to equal the users running the workflows on the server). In case you need further information regarding licensing details, please contact us at mail@seleniumnodes.com

Best,
Philipp

Hi Philipp,

Due to our Knime server have 5 users account, how much Selenium licenses does we need ? Is it possible for situation which just one account to run workflow with Selenium node but another 4 accounts not ?

Thanks,

Kin Chang

Hi,

  • was you original issue (importing the license file on the server) solved?
  • concerning the licensing situation, I’ve replied to your email.

– Philipp

Hi Philipp,

The issue is solved.
Thanks,

Kin Chang.